diff mbox

[03/11] pci: s/PCI_SUBVENDOR_ID/PCI_SUBSYSTEM_VENDOR_ID/g

Message ID 1260794906-30168-4-git-send-email-yamahata@valinux.co.jp
State New
Headers show

Commit Message

Isaku Yamahata Dec. 14, 2009, 12:48 p.m. UTC
To match Linux PCI register definition,
rename PCI_SUBVENDOR_ID to PCI_SUBSYSTEM_VENDOR_ID.

Signed-off-by: Isaku Yamahata <yamahata@valinux.co.jp>
---
 hw/pci.c |    2 +-
 hw/pci.h |    2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Michael S. Tsirkin Dec. 14, 2009, 1:36 p.m. UTC | #1
On Mon, Dec 14, 2009 at 09:48:18PM +0900, Isaku Yamahata wrote:
> To match Linux PCI register definition,
> rename PCI_SUBVENDOR_ID to PCI_SUBSYSTEM_VENDOR_ID.
> 
> Signed-off-by: Isaku Yamahata <yamahata@valinux.co.jp>

Acked-by: Michael S. Tsirkin <mst@redhat.com>

> ---
>  hw/pci.c |    2 +-
>  hw/pci.h |    2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/hw/pci.c b/hw/pci.c
> index 344d72b..fb03ee2 100644
> --- a/hw/pci.c
> +++ b/hw/pci.c
> @@ -411,7 +411,7 @@ static int pci_set_default_subsystem_id(PCIDevice *pci_dev)
>  {
>      uint16_t *id;
>  
> -    id = (void*)(&pci_dev->config[PCI_SUBVENDOR_ID]);
> +    id = (void*)(&pci_dev->config[PCI_SUBSYSTEM_VENDOR_ID]);
>      id[0] = cpu_to_le16(pci_default_sub_vendor_id);
>      id[1] = cpu_to_le16(pci_default_sub_device_id);
>      return 0;
> diff --git a/hw/pci.h b/hw/pci.h
> index d279e3f..0309674 100644
> --- a/hw/pci.h
> +++ b/hw/pci.h
> @@ -155,7 +155,7 @@ typedef struct PCIIORegion {
>  #define PCI_CAP_LIST_NEXT	1	/* Next capability in the list */
>  
>  #define PCI_REVISION            0x08    /* obsolete, use PCI_REVISION_ID */
> -#define PCI_SUBVENDOR_ID        0x2c    /* obsolete, use PCI_SUBSYSTEM_VENDOR_ID */
> +#define PCI_SUBSYSTEM_VENDOR_ID 0x2c
>  #define PCI_SUBDEVICE_ID        0x2e    /* obsolete, use PCI_SUBSYSTEM_ID */
>  
>  /* Bits in the PCI Status Register (PCI 2.3 spec) */
> -- 
> 1.6.5.4
diff mbox

Patch

diff --git a/hw/pci.c b/hw/pci.c
index 344d72b..fb03ee2 100644
--- a/hw/pci.c
+++ b/hw/pci.c
@@ -411,7 +411,7 @@  static int pci_set_default_subsystem_id(PCIDevice *pci_dev)
 {
     uint16_t *id;
 
-    id = (void*)(&pci_dev->config[PCI_SUBVENDOR_ID]);
+    id = (void*)(&pci_dev->config[PCI_SUBSYSTEM_VENDOR_ID]);
     id[0] = cpu_to_le16(pci_default_sub_vendor_id);
     id[1] = cpu_to_le16(pci_default_sub_device_id);
     return 0;
diff --git a/hw/pci.h b/hw/pci.h
index d279e3f..0309674 100644
--- a/hw/pci.h
+++ b/hw/pci.h
@@ -155,7 +155,7 @@  typedef struct PCIIORegion {
 #define PCI_CAP_LIST_NEXT	1	/* Next capability in the list */
 
 #define PCI_REVISION            0x08    /* obsolete, use PCI_REVISION_ID */
-#define PCI_SUBVENDOR_ID        0x2c    /* obsolete, use PCI_SUBSYSTEM_VENDOR_ID */
+#define PCI_SUBSYSTEM_VENDOR_ID 0x2c
 #define PCI_SUBDEVICE_ID        0x2e    /* obsolete, use PCI_SUBSYSTEM_ID */
 
 /* Bits in the PCI Status Register (PCI 2.3 spec) */