diff mbox

[PATCH/v2] powerpc/5200: make BestComm gen_bd microcode exchangeable

Message ID 1254764467.5503.1@antares (mailing list archive)
State Rejected
Delegated to: Grant Likely
Headers show

Commit Message

Albrecht Dreß Oct. 5, 2009, 5:41 p.m. UTC
This patch adds a method for defining different microcodes than the pe-defined ones for the MPC52xx's BestComm General Buffer Descriptor (gen_db) tasks.  The default microcode is still the one from bcom_gen_bd_[rt]x_task, but it can be replaced by calling bcom_gen_bd_set_microcode() which is more efficient than explicitly loading it via bcom_load_image() after each bcom_gen_bd_[rt]x_reset().

Except for a fixed tab vs. space formatting and the transfer format, there are no diffierences to the initial attempt.

Signed-off-by: Albrecht Dreß <albrecht.dress@arcor.de>


---

Comments

Grant Likely Oct. 5, 2009, 6:16 p.m. UTC | #1
On Mon, Oct 5, 2009 at 11:41 AM, Albrecht Dreß <albrecht.dress@arcor.de> wrote:
> This patch adds a method for defining different microcodes than the pe-defined ones for the MPC52xx's BestComm General Buffer Descriptor (gen_db) tasks.  The default microcode is still the one from bcom_gen_bd_[rt]x_task, but it can be replaced by calling bcom_gen_bd_set_microcode() which is more efficient than explicitly loading it via bcom_load_image() after each bcom_gen_bd_[rt]x_reset().
>
> Except for a fixed tab vs. space formatting and the transfer format, there are no diffierences to the initial attempt.

Hmmm.  I've not been comfortable with this change, but it took me a
while to put my finger on exactly why.  In principle, I think it is a
good idea.  However, I don't want to merge it without any in-tree
users.

The other concern is that I don't like that the patch is only
applicable to gen_bd tasks.  I've been thinking about this for a
while, and I'm not exactly thrilled with the bestcomm layout which
keeps the bestcomm firmware separate from the only driver that
actually uses it (ie FEC firmware & support code is separate from the
FEC driver.  Same for ATA).  I don't like the fact that code which is
only ever used by the ATA driver is maintained completely separate
from it.  But I may be splitting hairs here and maybe I shouldn't be
too concerned about it.  Regardless, I'd think I'd rather see
something that isn't totally gen_bd specific.  Perhaps *microcode
should be part of the bcom_task structure?

Thoughts?

g.

>
> Signed-off-by: Albrecht Dreß <albrecht.dress@arcor.de>
>
>
> ---
>
>
> diff -uprN -X linux-2.6.32-rc3/Documentation/dontdiff linux-2.6.32-rc3-orig/arch/powerpc/sysdev/bestcomm/gen_bd.c linux-2.6.32-rc3/arch/powerpc/sysdev/bestcomm/gen_bd.c
> --- linux-2.6.32-rc3-orig/arch/powerpc/sysdev/bestcomm/gen_bd.c 2009-10-05 02:12:30.000000000 +0200
> +++ linux-2.6.32-rc3/arch/powerpc/sysdev/bestcomm/gen_bd.c      2009-10-05 14:52:31.000000000 +0200
> @@ -78,6 +78,7 @@ struct bcom_gen_bd_priv {
>        int             initiator;
>        int             ipr;
>        int             maxbufsize;
> +       u32             *microcode;
>  };
>
>
> @@ -104,6 +105,7 @@ bcom_gen_bd_rx_init(int queue_len, phys_
>        priv->initiator = initiator;
>        priv->ipr       = ipr;
>        priv->maxbufsize = maxbufsize;
> +       priv->microcode = bcom_gen_bd_rx_task;
>
>        if (bcom_gen_bd_rx_reset(tsk)) {
>                bcom_task_free(tsk);
> @@ -128,7 +130,7 @@ bcom_gen_bd_rx_reset(struct bcom_task *t
>        var = (struct bcom_gen_bd_rx_var *) bcom_task_var(tsk->tasknum);
>        inc = (struct bcom_gen_bd_rx_inc *) bcom_task_inc(tsk->tasknum);
>
> -       if (bcom_load_image(tsk->tasknum, bcom_gen_bd_rx_task))
> +       if (bcom_load_image(tsk->tasknum, priv->microcode))
>                return -1;
>
>        var->enable     = bcom_eng->regs_base +
> @@ -188,6 +190,7 @@ bcom_gen_bd_tx_init(int queue_len, phys_
>        priv->fifo      = fifo;
>        priv->initiator = initiator;
>        priv->ipr       = ipr;
> +       priv->microcode = bcom_gen_bd_tx_task;
>
>        if (bcom_gen_bd_tx_reset(tsk)) {
>                bcom_task_free(tsk);
> @@ -212,7 +215,7 @@ bcom_gen_bd_tx_reset(struct bcom_task *t
>        var = (struct bcom_gen_bd_tx_var *) bcom_task_var(tsk->tasknum);
>        inc = (struct bcom_gen_bd_tx_inc *) bcom_task_inc(tsk->tasknum);
>
> -       if (bcom_load_image(tsk->tasknum, bcom_gen_bd_tx_task))
> +       if (bcom_load_image(tsk->tasknum, priv->microcode))
>                return -1;
>
>        var->enable     = bcom_eng->regs_base +
> @@ -253,6 +256,15 @@ bcom_gen_bd_tx_release(struct bcom_task
>  }
>  EXPORT_SYMBOL_GPL(bcom_gen_bd_tx_release);
>
> +void
> +bcom_gen_bd_set_microcode(struct bcom_task *tsk, u32 *microcode)
> +{
> +       struct bcom_gen_bd_priv *priv = tsk->priv;
> +
> +       priv->microcode = microcode;
> +}
> +EXPORT_SYMBOL_GPL(bcom_gen_bd_set_microcode);
> +
>  /* ---------------------------------------------------------------------
>  * PSC support code
>  */
> diff -uprN -X linux-2.6.32-rc3/Documentation/dontdiff linux-2.6.32-rc3-orig/arch/powerpc/sysdev/bestcomm/gen_bd.h linux-2.6.32-rc3/arch/powerpc/sysdev/bestcomm/gen_bd.h
> --- linux-2.6.32-rc3-orig/arch/powerpc/sysdev/bestcomm/gen_bd.h 2009-10-05 02:12:30.000000000 +0200
> +++ linux-2.6.32-rc3/arch/powerpc/sysdev/bestcomm/gen_bd.h      2009-10-05 14:52:31.000000000 +0200
> @@ -43,6 +43,9 @@ bcom_gen_bd_tx_reset(struct bcom_task *t
>  extern void
>  bcom_gen_bd_tx_release(struct bcom_task *tsk);
>
> +extern void
> +bcom_gen_bd_set_microcode(struct bcom_task *tsk, u32 *microcode);
> +
>
>  /* PSC support utility wrappers */
>  struct bcom_task * bcom_psc_gen_bd_rx_init(unsigned psc_num, int queue_len,
>
Grant Likely Nov. 1, 2009, 6:47 a.m. UTC | #2
On Mon, Oct 5, 2009 at 1:42 PM, Albrecht Dreß <albrecht.dress@arcor.de> wrote:
> Am 05.10.09 20:16 schrieb(en) Grant Likely:
>>
>> Hmmm.  I've not been comfortable with this change, but it took me a while
>> to put my finger on exactly why.  In principle, I think it is a good idea.
>>  However, I don't want to merge it without any in-tree users.
>
> I could provide my modified microcode (which differs in two words only), for
> the "standard" task, just with byte swapping for the LPB, but I wonder if it
> is of much use.  No progress with crc32 calculation in BestComm so far...
> :-(
>
>> The other concern is that I don't like that the patch is only applicable
>> to gen_bd tasks.
>
> IMHO the big difference between gen_bd on one hand and ATA and FEC on the
> other is that (afaik) we have *no* other choice than using the implemented
> tasks for the latter two, obviously using the Freescale's example microcode.
>  Gen_bd can apparently be used for a plenty of purposes, including LPB (as
> shown in your driver), maybe PCI (there are examples in Freescale's code),
> PSC, etc.  Thus, the FEC and ATA drivers should not have an option as to
> change the microcode, whereas it is just convenient for gen_bd.

agreed.

>> I've been thinking about this for a while, and I'm not exactly thrilled
>> with the bestcomm layout which keeps the bestcomm firmware separate from the
>> only driver that actually uses it (ie FEC firmware & support code is
>> separate from the FEC driver.  Same for ATA).  I don't like the fact that
>> code which is only ever used by the ATA driver is maintained completely
>> separate from it.
>
> That's a good point!  The separate microcode files for ATA and FEC are
> somewhat confusing.  I guess it's a result of simply copying the Freescale
> examples into separate files (and that might be a good reason for keeping
> the microcode separated).  Maybe create new sub-folders below
> arch/powerpc/sysdev/bestcomm for fec, ata, and gen_bd?  At least some
> documentation would be great.

No, that doesn't really help much.  The ATA and FEC microcode +
support functions really have no business living in the common
bestcomm directory at all.  I should look into moving that stuff right
into the FEC and ATA drivers.  The Bestcomm API is probably designed
to the wrong level, and the base API should expose the same task
loading interface to all uses, FEC, ATA, GenBD, and custom tasks.

>> But I may be splitting hairs here and maybe I shouldn't be too concerned
>> about it.  Regardless, I'd think I'd rather see something that isn't totally
>> gen_bd specific.  Perhaps *microcode should be part of the bcom_task
>> structure?
>
> See above - I believe FEC and ATA are somewhat special as they need
> *exactly* the provided microcode.  And if something cannot be changed
> without breaking the functionality, there should not be a chance to do so...
> ;-)

Hence the FEC and ATA microcode should live in (*gasp*) the FEC and
ATA drivers.  ;-)

g.
diff mbox

Patch

diff -uprN -X linux-2.6.32-rc3/Documentation/dontdiff linux-2.6.32-rc3-orig/arch/powerpc/sysdev/bestcomm/gen_bd.c linux-2.6.32-rc3/arch/powerpc/sysdev/bestcomm/gen_bd.c
--- linux-2.6.32-rc3-orig/arch/powerpc/sysdev/bestcomm/gen_bd.c	2009-10-05 02:12:30.000000000 +0200
+++ linux-2.6.32-rc3/arch/powerpc/sysdev/bestcomm/gen_bd.c	2009-10-05 14:52:31.000000000 +0200
@@ -78,6 +78,7 @@  struct bcom_gen_bd_priv {
 	int		initiator;
 	int		ipr;
 	int		maxbufsize;
+	u32		*microcode;
 };
 
 
@@ -104,6 +105,7 @@  bcom_gen_bd_rx_init(int queue_len, phys_
 	priv->initiator	= initiator;
 	priv->ipr	= ipr;
 	priv->maxbufsize = maxbufsize;
+	priv->microcode = bcom_gen_bd_rx_task;
 
 	if (bcom_gen_bd_rx_reset(tsk)) {
 		bcom_task_free(tsk);
@@ -128,7 +130,7 @@  bcom_gen_bd_rx_reset(struct bcom_task *t
 	var = (struct bcom_gen_bd_rx_var *) bcom_task_var(tsk->tasknum);
 	inc = (struct bcom_gen_bd_rx_inc *) bcom_task_inc(tsk->tasknum);
 
-	if (bcom_load_image(tsk->tasknum, bcom_gen_bd_rx_task))
+	if (bcom_load_image(tsk->tasknum, priv->microcode))
 		return -1;
 
 	var->enable	= bcom_eng->regs_base +
@@ -188,6 +190,7 @@  bcom_gen_bd_tx_init(int queue_len, phys_
 	priv->fifo	= fifo;
 	priv->initiator	= initiator;
 	priv->ipr	= ipr;
+	priv->microcode = bcom_gen_bd_tx_task;
 
 	if (bcom_gen_bd_tx_reset(tsk)) {
 		bcom_task_free(tsk);
@@ -212,7 +215,7 @@  bcom_gen_bd_tx_reset(struct bcom_task *t
 	var = (struct bcom_gen_bd_tx_var *) bcom_task_var(tsk->tasknum);
 	inc = (struct bcom_gen_bd_tx_inc *) bcom_task_inc(tsk->tasknum);
 
-	if (bcom_load_image(tsk->tasknum, bcom_gen_bd_tx_task))
+	if (bcom_load_image(tsk->tasknum, priv->microcode))
 		return -1;
 
 	var->enable	= bcom_eng->regs_base +
@@ -253,6 +256,15 @@  bcom_gen_bd_tx_release(struct bcom_task 
 }
 EXPORT_SYMBOL_GPL(bcom_gen_bd_tx_release);
 
+void
+bcom_gen_bd_set_microcode(struct bcom_task *tsk, u32 *microcode)
+{
+	struct bcom_gen_bd_priv *priv = tsk->priv;
+
+	priv->microcode = microcode;
+}
+EXPORT_SYMBOL_GPL(bcom_gen_bd_set_microcode);
+
 /* ---------------------------------------------------------------------
  * PSC support code
  */
diff -uprN -X linux-2.6.32-rc3/Documentation/dontdiff linux-2.6.32-rc3-orig/arch/powerpc/sysdev/bestcomm/gen_bd.h linux-2.6.32-rc3/arch/powerpc/sysdev/bestcomm/gen_bd.h
--- linux-2.6.32-rc3-orig/arch/powerpc/sysdev/bestcomm/gen_bd.h	2009-10-05 02:12:30.000000000 +0200
+++ linux-2.6.32-rc3/arch/powerpc/sysdev/bestcomm/gen_bd.h	2009-10-05 14:52:31.000000000 +0200
@@ -43,6 +43,9 @@  bcom_gen_bd_tx_reset(struct bcom_task *t
 extern void
 bcom_gen_bd_tx_release(struct bcom_task *tsk);
 
+extern void
+bcom_gen_bd_set_microcode(struct bcom_task *tsk, u32 *microcode);
+
 
 /* PSC support utility wrappers */
 struct bcom_task * bcom_psc_gen_bd_rx_init(unsigned psc_num, int queue_len,