diff mbox

sata_highbank: Rename proc_name to the module name

Message ID 1367341038-7335-1-git-send-email-rric@kernel.org
State Not Applicable
Delegated to: David Miller
Headers show

Commit Message

Robert Richter April 30, 2013, 4:57 p.m. UTC
From: Robert Richter <robert.richter@calxeda.com>

mkinitrd looks at /sys/class/scsi_host/host$hostnum/proc_name to find
the module name of a disk driver. Current name is "highbank-ahci" but
the module is "sata_highbank". Rename it to match the module name.

Cc: Rob Herring <rob.herring@calxeda.com>
Cc: Alexander Graf <agraf@suse.de>
Cc: <stable@vger.kernel.org> v3.7..
Signed-off-by: Robert Richter <robert.richter@calxeda.com>
---
 drivers/ata/sata_highbank.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Alexander Graf April 30, 2013, 4:59 p.m. UTC | #1
On 04/30/2013 06:57 PM, Robert Richter wrote:
> From: Robert Richter<robert.richter@calxeda.com>
>
> mkinitrd looks at /sys/class/scsi_host/host$hostnum/proc_name to find
> the module name of a disk driver. Current name is "highbank-ahci" but
> the module is "sata_highbank". Rename it to match the module name.
>
> Cc: Rob Herring<rob.herring@calxeda.com>
> Cc: Alexander Graf<agraf@suse.de>
> Cc:<stable@vger.kernel.org>  v3.7..
> Signed-off-by: Robert Richter<robert.richter@calxeda.com>

Acked-by: Alexander Graf <agraf@suse.de>


Alex

> ---
>   drivers/ata/sata_highbank.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/ata/sata_highbank.c b/drivers/ata/sata_highbank.c
> index 5dba77c..b1a664a 100644
> --- a/drivers/ata/sata_highbank.c
> +++ b/drivers/ata/sata_highbank.c
> @@ -251,7 +251,7 @@ static const struct ata_port_info ahci_highbank_port_info = {
>   };
>
>   static struct scsi_host_template ahci_highbank_platform_sht = {
> -	AHCI_SHT("highbank-ahci"),
> +	AHCI_SHT("sata_highbank"),
>   };
>
>   static const struct of_device_id ahci_of_match[] = {

--
To unsubscribe from this list: send the line "unsubscribe linux-ide" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Jeff Garzik April 30, 2013, 10:33 p.m. UTC | #2
On 04/30/2013 12:57 PM, Robert Richter wrote:
> From: Robert Richter <robert.richter@calxeda.com>
>
> mkinitrd looks at /sys/class/scsi_host/host$hostnum/proc_name to find
> the module name of a disk driver. Current name is "highbank-ahci" but
> the module is "sata_highbank". Rename it to match the module name.
>
> Cc: Rob Herring <rob.herring@calxeda.com>
> Cc: Alexander Graf <agraf@suse.de>
> Cc: <stable@vger.kernel.org> v3.7..
> Signed-off-by: Robert Richter <robert.richter@calxeda.com>
> ---
>   drivers/ata/sata_highbank.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)

applied



--
To unsubscribe from this list: send the line "unsubscribe linux-ide" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/ata/sata_highbank.c b/drivers/ata/sata_highbank.c
index 5dba77c..b1a664a 100644
--- a/drivers/ata/sata_highbank.c
+++ b/drivers/ata/sata_highbank.c
@@ -251,7 +251,7 @@  static const struct ata_port_info ahci_highbank_port_info = {
 };
 
 static struct scsi_host_template ahci_highbank_platform_sht = {
-	AHCI_SHT("highbank-ahci"),
+	AHCI_SHT("sata_highbank"),
 };
 
 static const struct of_device_id ahci_of_match[] = {