diff mbox

[v2] bswap: Fix width of swap in leul_to_cpu

Message ID 1359757608-1927-1-git-send-email-rth@twiddle.net
State New
Headers show

Commit Message

Richard Henderson Feb. 1, 2013, 10:26 p.m. UTC
The misnamed HOST_LONG_BITS is really HOST_POINTER_BITS.  Here we're
explicitly using an unsigned long, rather than uintptr_t, so it is
more correct to select the swap size via ULONG_MAX.

Signed-off-by: Richard Henderson <rth@twiddle.net>
---
 include/qemu/bswap.h | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)

This is the patch from 
  http://lists.gnu.org/archive/html/qemu-devel/2013-01/msg05868.html
with the commit message re-worded as per Andreas Färber feedback.


r~

Comments

Andreas Färber Feb. 2, 2013, 4:35 p.m. UTC | #1
Am 01.02.2013 23:26, schrieb Richard Henderson:
> The misnamed HOST_LONG_BITS is really HOST_POINTER_BITS.  Here we're
> explicitly using an unsigned long, rather than uintptr_t, so it is
> more correct to select the swap size via ULONG_MAX.
> 
> Signed-off-by: Richard Henderson <rth@twiddle.net>

Acked-by: Andreas Färber <afaerber@suse.de>

Fixes a warning when including qemu/bswap.h from tests/tmp105-test.c.

Thanks,
Andreas
Anthony Liguori Feb. 6, 2013, 8:41 p.m. UTC | #2
Applied.  Thanks.

Regards,

Anthony Liguori
diff mbox

Patch

diff --git a/include/qemu/bswap.h b/include/qemu/bswap.h
index e6d4798..d3af35d 100644
--- a/include/qemu/bswap.h
+++ b/include/qemu/bswap.h
@@ -2,8 +2,8 @@ 
 #define BSWAP_H
 
 #include "config-host.h"
-
 #include <inttypes.h>
+#include <limits.h>
 #include "fpu/softfloat.h"
 
 #ifdef CONFIG_MACHINE_BSWAP_H
@@ -458,7 +458,15 @@  static inline void cpu_to_32wu(uint32_t *p, uint32_t v)
 
 static inline unsigned long leul_to_cpu(unsigned long v)
 {
-    return le_bswap(v, HOST_LONG_BITS);
+    /* In order to break an include loop between here and
+       qemu-common.h, don't rely on HOST_LONG_BITS.  */
+#if ULONG_MAX == UINT32_MAX
+    return le_bswap(v, 32);
+#elif ULONG_MAX == UINT64_MAX
+    return le_bswap(v, 64);
+#else
+# error Unknown sizeof long
+#endif
 }
 
 #undef le_bswap