diff mbox

ARM: tegra: rename the file of "sleep-tXX" to "sleep-tegraXX"

Message ID 1349691837-30488-1-git-send-email-josephl@nvidia.com
State Accepted, archived
Headers show

Commit Message

Joseph Lo Oct. 8, 2012, 10:23 a.m. UTC
For the naming consistency under the mach-tegra, we re-name the file of
"sleep-tXX" to "sleep-tegraXX" (e.g., sleep-t30 to sleep-tegra30).

Signed-off-by: Joseph Lo <josephl@nvidia.com>
---
 arch/arm/mach-tegra/Makefile                       |    4 ++--
 .../mach-tegra/{sleep-t20.S => sleep-tegra20.S}    |    0
 .../mach-tegra/{sleep-t30.S => sleep-tegra30.S}    |    0
 3 files changed, 2 insertions(+), 2 deletions(-)
 rename arch/arm/mach-tegra/{sleep-t20.S => sleep-tegra20.S} (100%)
 rename arch/arm/mach-tegra/{sleep-t30.S => sleep-tegra30.S} (100%)

diff --git a/arch/arm/mach-tegra/sleep-t20.S b/arch/arm/mach-tegra/sleep-tegra20.S
similarity index 100%
rename from arch/arm/mach-tegra/sleep-t20.S
rename to arch/arm/mach-tegra/sleep-tegra20.S
diff --git a/arch/arm/mach-tegra/sleep-t30.S b/arch/arm/mach-tegra/sleep-tegra30.S
similarity index 100%
rename from arch/arm/mach-tegra/sleep-t30.S
rename to arch/arm/mach-tegra/sleep-tegra30.S

Comments

Olof Johansson Oct. 10, 2012, 8:54 p.m. UTC | #1
On Mon, Oct 8, 2012 at 3:23 AM, Joseph Lo <josephl@nvidia.com> wrote:
> For the naming consistency under the mach-tegra, we re-name the file of
> "sleep-tXX" to "sleep-tegraXX" (e.g., sleep-t30 to sleep-tegra30).
>
> Signed-off-by: Joseph Lo <josephl@nvidia.com>

Why rename? It's just churn.


-Olof
--
To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Stephen Warren Oct. 10, 2012, 9:07 p.m. UTC | #2
On 10/10/2012 02:54 PM, Olof Johansson wrote:
> On Mon, Oct 8, 2012 at 3:23 AM, Joseph Lo <josephl@nvidia.com> wrote:
>> For the naming consistency under the mach-tegra, we re-name the file of
>> "sleep-tXX" to "sleep-tegraXX" (e.g., sleep-t30 to sleep-tegra30).
>>
>> Signed-off-by: Joseph Lo <josephl@nvidia.com>
> 
> Why rename? It's just churn.

The CPUs are named TegraNN not TNN, so for consistency the files should
be named that way. This is almost the last instance; everything else got
renamed as a side-effect of adding splitting things up for Tegra30
support. Oh, except tegra2_emc.c which can be renamed whenever it's
moved to an appropriate drivers/ directory.

--
To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Olof Johansson Oct. 10, 2012, 10:22 p.m. UTC | #3
On Wed, Oct 10, 2012 at 2:07 PM, Stephen Warren <swarren@wwwdotorg.org> wrote:
> On 10/10/2012 02:54 PM, Olof Johansson wrote:
>> On Mon, Oct 8, 2012 at 3:23 AM, Joseph Lo <josephl@nvidia.com> wrote:
>>> For the naming consistency under the mach-tegra, we re-name the file of
>>> "sleep-tXX" to "sleep-tegraXX" (e.g., sleep-t30 to sleep-tegra30).
>>>
>>> Signed-off-by: Joseph Lo <josephl@nvidia.com>
>>
>> Why rename? It's just churn.
>
> The CPUs are named TegraNN not TNN, so for consistency the files should
> be named that way. This is almost the last instance; everything else got
> renamed as a side-effect of adding splitting things up for Tegra30
> support. Oh, except tegra2_emc.c which can be renamed whenever it's
> moved to an appropriate drivers/ directory.


Marketing names are irrelevant and tend to change over time. But ok,
if it's the last renames pending then I think we can be OK with it.


-Olof
--
To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/arch/arm/mach-tegra/Makefile b/arch/arm/mach-tegra/Makefile
index 9aa653b..e6929c6 100644
--- a/arch/arm/mach-tegra/Makefile
+++ b/arch/arm/mach-tegra/Makefile
@@ -13,10 +13,10 @@  obj-$(CONFIG_CPU_IDLE)			+= sleep.o
 obj-$(CONFIG_ARCH_TEGRA_2x_SOC)         += tegra20_clocks.o
 obj-$(CONFIG_ARCH_TEGRA_2x_SOC)         += tegra20_clocks_data.o
 obj-$(CONFIG_ARCH_TEGRA_2x_SOC)		+= tegra2_emc.o
-obj-$(CONFIG_ARCH_TEGRA_2x_SOC)		+= sleep-t20.o
+obj-$(CONFIG_ARCH_TEGRA_2x_SOC)		+= sleep-tegra20.o
 obj-$(CONFIG_ARCH_TEGRA_3x_SOC)		+= tegra30_clocks.o
 obj-$(CONFIG_ARCH_TEGRA_3x_SOC)		+= tegra30_clocks_data.o
-obj-$(CONFIG_ARCH_TEGRA_3x_SOC)		+= sleep-t30.o
+obj-$(CONFIG_ARCH_TEGRA_3x_SOC)		+= sleep-tegra30.o
 obj-$(CONFIG_SMP)			+= platsmp.o headsmp.o
 obj-$(CONFIG_SMP)                       += reset.o
 obj-$(CONFIG_HOTPLUG_CPU)               += hotplug.o