diff mbox

[net-next] af_packet: use define instead of constant

Message ID 1345469643.22726.2.camel@thinkbox
State Accepted, archived
Delegated to: David Miller
Headers show

Commit Message

danborkmann@iogearbox.net Aug. 20, 2012, 1:34 p.m. UTC
Instead of using a hard-coded value for the status variable, it would make
the code more readable to use its destined define from linux/if_packet.h.

Signed-off-by: daniel.borkmann@tik.ee.ethz.ch
---
 net/packet/af_packet.c |    5 +++--
 1 files changed, 3 insertions(+), 2 deletions(-)


--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Comments

David Miller Aug. 23, 2012, 5:58 a.m. UTC | #1
From: Daniel Borkmann <danborkmann@iogearbox.net>
Date: Mon, 20 Aug 2012 15:34:03 +0200

> Instead of using a hard-coded value for the status variable, it would make
> the code more readable to use its destined define from linux/if_packet.h.
> 
> Signed-off-by: daniel.borkmann@tik.ee.ethz.ch

Applied.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
index 226b2cd..3ee372a 100644
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
@@ -855,7 +855,8 @@  static void prb_fill_vlan_info(struct tpacket_kbdq_core *pkc,
 		ppd->hv1.tp_vlan_tci = vlan_tx_tag_get(pkc->skb);
 		ppd->tp_status = TP_STATUS_VLAN_VALID;
 	} else {
-		ppd->hv1.tp_vlan_tci = ppd->tp_status = 0;
+		ppd->hv1.tp_vlan_tci = 0;
+		ppd->tp_status = TP_STATUS_AVAILABLE;
 	}
 }
 
@@ -1943,7 +1944,7 @@  static int tpacket_snd(struct packet_sock *po, struct msghdr *msg)
 	int tp_len, size_max;
 	unsigned char *addr;
 	int len_sum = 0;
-	int status = 0;
+	int status = TP_STATUS_AVAILABLE;
 	int hlen, tlen;
 
 	mutex_lock(&po->pg_vec_lock);