diff mbox

[v2,6/6] msix: Fix last PCIDevice naming inconsitency

Message ID 20120614045205.11034.781.stgit@bling.home
State New
Headers show

Commit Message

Alex Williamson June 14, 2012, 4:52 a.m. UTC
The previous patches fixed almost all the inconsistent names used
for PCIDevice in msix.c, fix the one remaining transgression.

Signed-off-by: Alex Williamson <alex.williamson@redhat.com>
---

 hw/msix.h |    3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Michael S. Tsirkin June 14, 2012, 8:13 a.m. UTC | #1
On Wed, Jun 13, 2012 at 10:52:06PM -0600, Alex Williamson wrote:
> The previous patches fixed almost all the inconsistent names used
> for PCIDevice in msix.c, fix the one remaining transgression.
> 
> Signed-off-by: Alex Williamson <alex.williamson@redhat.com>

Except, would be better to first rename parameters and
do other mechanical changes, and then apply your diff
on top.

As it is the patch looks like it rewrites everything while
it could be a very small one.

> ---
> 
>  hw/msix.h |    3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/hw/msix.h b/hw/msix.h
> index 14b1a2e..1786e27 100644
> --- a/hw/msix.h
> +++ b/hw/msix.h
> @@ -11,8 +11,7 @@ int msix_init(PCIDevice *dev, unsigned short nentries,
>  int msix_init_exclusive_bar(PCIDevice *dev, unsigned short nentries,
>                              uint8_t bar_nr);
>  
> -void msix_write_config(PCIDevice *pci_dev, uint32_t address,
> -                       uint32_t val, int len);
> +void msix_write_config(PCIDevice *dev, uint32_t address, uint32_t val, int len);
>  
>  void msix_uninit(PCIDevice *dev, MemoryRegion *table_bar,
>                   MemoryRegion *pba_bar);
Alex Williamson June 14, 2012, 2:18 p.m. UTC | #2
On Thu, 2012-06-14 at 11:13 +0300, Michael S. Tsirkin wrote:
> On Wed, Jun 13, 2012 at 10:52:06PM -0600, Alex Williamson wrote:
> > The previous patches fixed almost all the inconsistent names used
> > for PCIDevice in msix.c, fix the one remaining transgression.
> > 
> > Signed-off-by: Alex Williamson <alex.williamson@redhat.com>
> 
> Except, would be better to first rename parameters and
> do other mechanical changes, and then apply your diff
> on top.
> 
> As it is the patch looks like it rewrites everything while
> it could be a very small one.

You're welcome for trying to add consistency, sorry I pointed it out.

> > ---
> > 
> >  hw/msix.h |    3 +--
> >  1 file changed, 1 insertion(+), 2 deletions(-)
> > 
> > diff --git a/hw/msix.h b/hw/msix.h
> > index 14b1a2e..1786e27 100644
> > --- a/hw/msix.h
> > +++ b/hw/msix.h
> > @@ -11,8 +11,7 @@ int msix_init(PCIDevice *dev, unsigned short nentries,
> >  int msix_init_exclusive_bar(PCIDevice *dev, unsigned short nentries,
> >                              uint8_t bar_nr);
> >  
> > -void msix_write_config(PCIDevice *pci_dev, uint32_t address,
> > -                       uint32_t val, int len);
> > +void msix_write_config(PCIDevice *dev, uint32_t address, uint32_t val, int len);
> >  
> >  void msix_uninit(PCIDevice *dev, MemoryRegion *table_bar,
> >                   MemoryRegion *pba_bar);
Michael S. Tsirkin June 14, 2012, 2:21 p.m. UTC | #3
On Thu, Jun 14, 2012 at 08:18:10AM -0600, Alex Williamson wrote:
> On Thu, 2012-06-14 at 11:13 +0300, Michael S. Tsirkin wrote:
> > On Wed, Jun 13, 2012 at 10:52:06PM -0600, Alex Williamson wrote:
> > > The previous patches fixed almost all the inconsistent names used
> > > for PCIDevice in msix.c, fix the one remaining transgression.
> > > 
> > > Signed-off-by: Alex Williamson <alex.williamson@redhat.com>
> > 
> > Except, would be better to first rename parameters and
> > do other mechanical changes, and then apply your diff
> > on top.
> > 
> > As it is the patch looks like it rewrites everything while
> > it could be a very small one.
> 
> You're welcome for trying to add consistency, sorry I pointed it out.

No problem with this patch itself though.

> > > ---
> > > 
> > >  hw/msix.h |    3 +--
> > >  1 file changed, 1 insertion(+), 2 deletions(-)
> > > 
> > > diff --git a/hw/msix.h b/hw/msix.h
> > > index 14b1a2e..1786e27 100644
> > > --- a/hw/msix.h
> > > +++ b/hw/msix.h
> > > @@ -11,8 +11,7 @@ int msix_init(PCIDevice *dev, unsigned short nentries,
> > >  int msix_init_exclusive_bar(PCIDevice *dev, unsigned short nentries,
> > >                              uint8_t bar_nr);
> > >  
> > > -void msix_write_config(PCIDevice *pci_dev, uint32_t address,
> > > -                       uint32_t val, int len);
> > > +void msix_write_config(PCIDevice *dev, uint32_t address, uint32_t val, int len);
> > >  
> > >  void msix_uninit(PCIDevice *dev, MemoryRegion *table_bar,
> > >                   MemoryRegion *pba_bar);
> 
>
Michael S. Tsirkin June 14, 2012, 3:06 p.m. UTC | #4
On Thu, Jun 14, 2012 at 08:18:10AM -0600, Alex Williamson wrote:
> On Thu, 2012-06-14 at 11:13 +0300, Michael S. Tsirkin wrote:
> > On Wed, Jun 13, 2012 at 10:52:06PM -0600, Alex Williamson wrote:
> > > The previous patches fixed almost all the inconsistent names used
> > > for PCIDevice in msix.c, fix the one remaining transgression.
> > > 
> > > Signed-off-by: Alex Williamson <alex.williamson@redhat.com>
> > 
> > Except, would be better to first rename parameters and
> > do other mechanical changes, and then apply your diff
> > on top.
> > 
> > As it is the patch looks like it rewrites everything while
> > it could be a very small one.
> 
> You're welcome for trying to add consistency, sorry I pointed it out.

Typo: patch should have been "patch set".
I was talking about the rest of the changes, this patch looks fine
actually. Sorry about the confusion.


> > > ---
> > > 
> > >  hw/msix.h |    3 +--
> > >  1 file changed, 1 insertion(+), 2 deletions(-)
> > > 
> > > diff --git a/hw/msix.h b/hw/msix.h
> > > index 14b1a2e..1786e27 100644
> > > --- a/hw/msix.h
> > > +++ b/hw/msix.h
> > > @@ -11,8 +11,7 @@ int msix_init(PCIDevice *dev, unsigned short nentries,
> > >  int msix_init_exclusive_bar(PCIDevice *dev, unsigned short nentries,
> > >                              uint8_t bar_nr);
> > >  
> > > -void msix_write_config(PCIDevice *pci_dev, uint32_t address,
> > > -                       uint32_t val, int len);
> > > +void msix_write_config(PCIDevice *dev, uint32_t address, uint32_t val, int len);
> > >  
> > >  void msix_uninit(PCIDevice *dev, MemoryRegion *table_bar,
> > >                   MemoryRegion *pba_bar);
> 
>
Michael S. Tsirkin June 14, 2012, 3:08 p.m. UTC | #5
On Wed, Jun 13, 2012 at 10:52:06PM -0600, Alex Williamson wrote:
> The previous patches fixed almost all the inconsistent names used
> for PCIDevice in msix.c, fix the one remaining transgression.
> 
> Signed-off-by: Alex Williamson <alex.williamson@redhat.com>

Tweaked the commit log as it's not the last patch in
the commit stream anymore and applied, thanks.

> ---
> 
>  hw/msix.h |    3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/hw/msix.h b/hw/msix.h
> index 14b1a2e..1786e27 100644
> --- a/hw/msix.h
> +++ b/hw/msix.h
> @@ -11,8 +11,7 @@ int msix_init(PCIDevice *dev, unsigned short nentries,
>  int msix_init_exclusive_bar(PCIDevice *dev, unsigned short nentries,
>                              uint8_t bar_nr);
>  
> -void msix_write_config(PCIDevice *pci_dev, uint32_t address,
> -                       uint32_t val, int len);
> +void msix_write_config(PCIDevice *dev, uint32_t address, uint32_t val, int len);
>  
>  void msix_uninit(PCIDevice *dev, MemoryRegion *table_bar,
>                   MemoryRegion *pba_bar);
diff mbox

Patch

diff --git a/hw/msix.h b/hw/msix.h
index 14b1a2e..1786e27 100644
--- a/hw/msix.h
+++ b/hw/msix.h
@@ -11,8 +11,7 @@  int msix_init(PCIDevice *dev, unsigned short nentries,
 int msix_init_exclusive_bar(PCIDevice *dev, unsigned short nentries,
                             uint8_t bar_nr);
 
-void msix_write_config(PCIDevice *pci_dev, uint32_t address,
-                       uint32_t val, int len);
+void msix_write_config(PCIDevice *dev, uint32_t address, uint32_t val, int len);
 
 void msix_uninit(PCIDevice *dev, MemoryRegion *table_bar,
                  MemoryRegion *pba_bar);