mbox

pull request: batman-adv 2012-05-11

Message ID 1336738892-7401-1-git-send-email-ordex@autistici.org
State Accepted, archived
Delegated to: David Miller
Headers show

Pull-request

git://git.open-mesh.org/linux-merge.git tags/batman-adv-for-davem

Message

Antonio Quartulli May 11, 2012, 12:21 p.m. UTC
Hello David,

this is a fixed version of the pull request issued on 2012-05-09.

Comments introduced in this patchset are not following the net-tree
guidelines. Another patch changing all the already existing comments will follow
later. 

New exported functions follow the new name convention we discussed so far.
A patch renaming all the existing exported functions will follow.



Please let me know if there is any problem.
Thank you,
	Antonio


The following changes since commit 06a4c1c55dbe5d9f7a708e8f1a52fd2ac8e5874f:

  6lowpan: IPv6 link local address (2012-05-10 23:38:22 -0400)

are available in the git repository at:

  git://git.open-mesh.org/linux-merge.git tags/batman-adv-for-davem

for you to fetch changes up to 35c133a000d54b7e3fe81e8c8e4b8af5878ad6dd:

  batman-adv: add contributor name (2012-05-11 13:56:08 +0200)

----------------------------------------------------------------
Included changes:

* fix a little bug in the DHCP packet snooping introduced so far
* minor fixes and cleanups
* minor routing protocol API cleanups
* add a new contributor name to translation-table.{c,h}
* update copyright years in file headers
* minor improvement for the routing algorithm

----------------------------------------------------------------
Antonio Quartulli (3):
      batman-adv: fix wrong dhcp option list browsing
      batman-adv: update copyright years
      batman-adv: add contributor name

Linus Luessing (1):
      batman-adv: Adding hard_iface specific sysfs wrapper macros for UINT

Marek Lindner (11):
      batman-adv: introduce is_single_hop_neigh variable to increase readability
      batman-adv: introduce packet type handler array for incoming packets
      batman-adv: register batman ogm receive function during protocol init
      batman-adv: rename last_valid to last_seen
      batman-adv: replace HZ calculations with jiffies_to_msecs()
      batman-adv: split neigh_new function into generic and batman iv specific parts
      batman-adv: ignore protocol packets if the interface did not enable this protocol
      batman-adv: refactoring API: find generalized name for bat_ogm_update_mac callback
      batman-adv: rename sysfs macros to reflect the soft-interface dependency
      batman-adv: avoid temporary routing loops by being strict on forwarded OGMs
      batman-adv: fix checkpatch string complaint

 net/batman-adv/bat_debugfs.c           |    4 +-
 net/batman-adv/bat_iv_ogm.c            |  176 +++++++++++++++++++++-----------
 net/batman-adv/bat_sysfs.c             |  100 +++++++++++++-----
 net/batman-adv/bridge_loop_avoidance.c |    2 +-
 net/batman-adv/bridge_loop_avoidance.h |    2 +-
 net/batman-adv/gateway_client.c        |    6 +-
 net/batman-adv/hard-interface.c        |  117 +--------------------
 net/batman-adv/main.c                  |  124 +++++++++++++++++++++-
 net/batman-adv/main.h                  |    6 ++
 net/batman-adv/originator.c            |   51 +++++----
 net/batman-adv/originator.h            |    7 +-
 net/batman-adv/packet.h                |    1 +
 net/batman-adv/routing.c               |   22 ++--
 net/batman-adv/routing.h               |    4 +-
 net/batman-adv/send.c                  |    2 +-
 net/batman-adv/translation-table.c     |    2 +-
 net/batman-adv/translation-table.h     |    2 +-
 net/batman-adv/types.h                 |   17 ++-
 18 files changed, 380 insertions(+), 265 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Comments

David Miller May 11, 2012, 10:01 p.m. UTC | #1
From: Antonio Quartulli <ordex@autistici.org>
Date: Fri, 11 May 2012 14:21:17 +0200

> this is a fixed version of the pull request issued on 2012-05-09.
> 
> Comments introduced in this patchset are not following the net-tree
> guidelines. Another patch changing all the already existing comments will follow
> later. 
> 
> New exported functions follow the new name convention we discussed so far.
> A patch renaming all the existing exported functions will follow.

Pulled, but you have to cleanup the namespace on lots of other
functions too.

For example, the packet receive handle register/unregister routines
you added in this series as well.

Go through the entire batman-adv stack, and if the function or data
object is not static, make sure it has a batadv_*() prefix.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Sven Eckelmann May 11, 2012, 10:10 p.m. UTC | #2
On Friday, May 11, 2012 06:01:44 PM David Miller wrote:
> From: Antonio Quartulli <ordex@autistici.org>
> Date: Fri, 11 May 2012 14:21:17 +0200
> 
> > this is a fixed version of the pull request issued on 2012-05-09.
> > 
> > Comments introduced in this patchset are not following the net-tree
> > guidelines. Another patch changing all the already existing comments
> > will follow later.
> > 
> > New exported functions follow the new name convention we discussed so
> > far. A patch renaming all the existing exported functions will follow.
> Pulled, but you have to cleanup the namespace on lots of other
> functions too.
> 
> For example, the packet receive handle register/unregister routines
> you added in this series as well.
> 
> Go through the entire batman-adv stack, and if the function or data
> object is not static, make sure it has a batadv_*() prefix.

The patches for this are posted on the batman-adv mailinglist [1]. I am 
currently splitting this large patch for easier consumption.

Thanks,
	Sven

[1] https://lists.open-mesh.org/pipermail/b.a.t.m.a.n/2012-May/007062.html