diff mbox

[1/2] UBI: fix documentation and improve readability

Message ID 1331216491-6728-1-git-send-email-dedekind1@gmail.com
State Accepted
Commit add8287e3fa2160229117c9e1b7c9ca8cb661423
Headers show

Commit Message

Artem Bityutskiy March 8, 2012, 2:21 p.m. UTC
From: Artem Bityutskiy <artem.bityutskiy@linux.intel.com>

The "max" parameter of 'find_wl_entry()' was documented incorrectly and
it actually means the maximum possible difference from th smallest erase
counter. Rename it to "diff" instead, and amend the documentation.

Reported-by: Shmulik Ladkani <shmulik.ladkani@gmail.com>
Signed-off-by: Artem Bityutskiy <artem.bityutskiy@linux.intel.com>
Reviewed-by: Shmulik Ladkani <shmulik.ladkani@gmail.com>
---
 drivers/mtd/ubi/wl.c |    9 +++++----
 1 files changed, 5 insertions(+), 4 deletions(-)

Comments

Shmulik Ladkani March 8, 2012, 3:57 p.m. UTC | #1
On Thu,  8 Mar 2012 16:21:30 +0200 Artem Bityutskiy <dedekind1@gmail.com> wrote:
> From: Artem Bityutskiy <artem.bityutskiy@linux.intel.com>
> 
> The "max" parameter of 'find_wl_entry()' was documented incorrectly and
> it actually means the maximum possible difference from th smallest erase

s/ th / the /

Regards,
Shmulik
Artem Bityutskiy March 9, 2012, 7:43 a.m. UTC | #2
On Thu, 2012-03-08 at 17:57 +0200, Shmulik Ladkani wrote:
> On Thu,  8 Mar 2012 16:21:30 +0200 Artem Bityutskiy <dedekind1@gmail.com> wrote:
> > From: Artem Bityutskiy <artem.bityutskiy@linux.intel.com>
> > 
> > The "max" parameter of 'find_wl_entry()' was documented incorrectly and
> > it actually means the maximum possible difference from th smallest erase
> 
> s/ th / the /

Fixed, thanks!
diff mbox

Patch

diff --git a/drivers/mtd/ubi/wl.c b/drivers/mtd/ubi/wl.c
index 0696e36..8616f52 100644
--- a/drivers/mtd/ubi/wl.c
+++ b/drivers/mtd/ubi/wl.c
@@ -350,18 +350,19 @@  static void prot_queue_add(struct ubi_device *ubi, struct ubi_wl_entry *e)
 /**
  * find_wl_entry - find wear-leveling entry closest to certain erase counter.
  * @root: the RB-tree where to look for
- * @max: highest possible erase counter
+ * @diff: maximum possible difference from the smallest erase counter
  *
  * This function looks for a wear leveling entry with erase counter closest to
- * @max and less than @max.
+ * min + @diff, where min is the smallest erase counter.
  */
-static struct ubi_wl_entry *find_wl_entry(struct rb_root *root, int max)
+static struct ubi_wl_entry *find_wl_entry(struct rb_root *root, int diff)
 {
 	struct rb_node *p;
 	struct ubi_wl_entry *e;
+	int max;
 
 	e = rb_entry(rb_first(root), struct ubi_wl_entry, u.rb);
-	max += e->ec;
+	max = e->ec + diff;
 
 	p = root->rb_node;
 	while (p) {