diff mbox

[2/5] qom/object.c: rename type_class_init() to type_initialize()

Message ID 1330688145-22944-3-git-send-email-i.mitsyanko@samsung.com
State New
Headers show

Commit Message

Mitsyanko Igor March 2, 2012, 11:35 a.m. UTC
Function name type_class_init() gave us a wrong impression of separation
of type's "class" and "object" entities initialization. Name type_initialize()
is more appropriate for type_class_init() function (considering what operations
it performs).

Signed-off-by: Igor Mitsyanko <i.mitsyanko@samsung.com>
Reviewed-by: Paolo Bonzini <pbonzini@redhat.com>
---
 qom/object.c |   12 ++++++------
 1 files changed, 6 insertions(+), 6 deletions(-)

Comments

Peter Maydell March 6, 2012, 6:52 p.m. UTC | #1
On 2 March 2012 11:35, Igor Mitsyanko <i.mitsyanko@samsung.com> wrote:
> Function name type_class_init() gave us a wrong impression of separation
> of type's "class" and "object" entities initialization. Name type_initialize()
> is more appropriate for type_class_init() function (considering what operations
> it performs).
>
> Signed-off-by: Igor Mitsyanko <i.mitsyanko@samsung.com>
> Reviewed-by: Paolo Bonzini <pbonzini@redhat.com>

The later patches in this series don't depend on this one, surely?
Assuming that's correct, this patch should go in directly, not
via arm-devs, and it shouldn't be in this series.

thanks
-- PMM
diff mbox

Patch

diff --git a/qom/object.c b/qom/object.c
index 6d31bc3..9acc624 100644
--- a/qom/object.c
+++ b/qom/object.c
@@ -206,7 +206,7 @@  static void type_class_interface_init(TypeImpl *ti, InterfaceImpl *iface)
     g_free(name);
 }
 
-static void type_class_init(TypeImpl *ti)
+static void type_initialize(TypeImpl *ti)
 {
     size_t class_size = sizeof(ObjectClass);
     int i;
@@ -224,7 +224,7 @@  static void type_class_init(TypeImpl *ti)
     if (type_has_parent(ti)) {
         TypeImpl *parent = type_get_parent(ti);
 
-        type_class_init(parent);
+        type_initialize(parent);
 
         class_size = parent->class_size;
         g_assert(parent->class_size <= ti->class_size);
@@ -278,7 +278,7 @@  void object_initialize_with_type(void *data, TypeImpl *type)
     Object *obj = data;
 
     g_assert(type != NULL);
-    type_class_init(type);
+    type_initialize(type);
 
     g_assert(type->instance_size >= sizeof(Object));
     g_assert(type->abstract == false);
@@ -370,7 +370,7 @@  Object *object_new_with_type(Type type)
     Object *obj;
 
     g_assert(type != NULL);
-    type_class_init(type);
+    type_initialize(type);
 
     obj = g_malloc(type->instance_size);
     object_initialize_with_type(obj, type);
@@ -543,7 +543,7 @@  ObjectClass *object_class_by_name(const char *typename)
         return NULL;
     }
 
-    type_class_init(type);
+    type_initialize(type);
 
     return type->class;
 }
@@ -563,7 +563,7 @@  static void object_class_foreach_tramp(gpointer key, gpointer value,
     TypeImpl *type = value;
     ObjectClass *k;
 
-    type_class_init(type);
+    type_initialize(type);
     k = type->class;
 
     if (!data->include_abstract && type->abstract) {