diff mbox

[U-Boot,v6,1/2] i2c:gpio:s5p: I2C GPIO Software implementation (via soft_i2c)

Message ID 1314088499-7572-2-git-send-email-l.majewski@samsung.com
State Accepted
Commit 9f15bc0c1cc1a88ee655ea2dc3dd56caf8e5de79
Delegated to: Minkyu Kang
Headers show

Commit Message

Łukasz Majewski Aug. 23, 2011, 8:34 a.m. UTC
This patch adds support for software I2C for GONI and Universal C210 reference targets.
It adds support for access to GPIOs by number, not as it is present,
by bank and offset.

Signed-off-by: Lukasz Majewski <l.majewski@samsung.com>
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
Cc: Minkyu Kang <mk7.kang@samsung.com>
Cc: Heiko Schocher <hs@denx.de>

---
Changes for v2:
	- Generic GPIO code added to arch/arm/gpio.h
	- Platform dependent GPIO code added to board/samsung/goni.c
	- Code cleanup
Changes for v3:
	- I2C GPIO common code added to drivers/gpio/s5p_gpio.c
	- i2c_init_board() function added(required by soft_i2c)
Changes for v4:
	- i2x_init_board() removed
	- s5pc210 support added
	- GPIO code and I2C enable code split to separate patches
Changes for v5:
	- s5p_gpio pointer removed and replaced with generic s5p_gpio_base
	function
	- removed duplicated code
Changes for v6:
	- s5pc[1|2]10_gpio_get_nr macro added. More redable code for I2C
        gpio pins definition
---
 arch/arm/include/asm/arch-s5pc1xx/gpio.h |   13 +++++++++
 arch/arm/include/asm/arch-s5pc2xx/gpio.h |   29 +++++++++++++++++++
 drivers/gpio/s5p_gpio.c                  |   44 ++++++++++++++++++++++++++++++
 3 files changed, 86 insertions(+), 0 deletions(-)

Comments

Minkyu Kang Aug. 30, 2011, 3:47 a.m. UTC | #1
Dear Lukasz Majewski,

On 23 August 2011 17:34, Lukasz Majewski <l.majewski@samsung.com> wrote:
> This patch adds support for software I2C for GONI and Universal C210 reference targets.
> It adds support for access to GPIOs by number, not as it is present,
> by bank and offset.
>
> Signed-off-by: Lukasz Majewski <l.majewski@samsung.com>
> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
> Cc: Minkyu Kang <mk7.kang@samsung.com>
> Cc: Heiko Schocher <hs@denx.de>
>
> ---
> Changes for v2:
>        - Generic GPIO code added to arch/arm/gpio.h
>        - Platform dependent GPIO code added to board/samsung/goni.c
>        - Code cleanup
> Changes for v3:
>        - I2C GPIO common code added to drivers/gpio/s5p_gpio.c
>        - i2c_init_board() function added(required by soft_i2c)
> Changes for v4:
>        - i2x_init_board() removed
>        - s5pc210 support added
>        - GPIO code and I2C enable code split to separate patches
> Changes for v5:
>        - s5p_gpio pointer removed and replaced with generic s5p_gpio_base
>        function
>        - removed duplicated code
> Changes for v6:
>        - s5pc[1|2]10_gpio_get_nr macro added. More redable code for I2C
>        gpio pins definition
> ---
>  arch/arm/include/asm/arch-s5pc1xx/gpio.h |   13 +++++++++
>  arch/arm/include/asm/arch-s5pc2xx/gpio.h |   29 +++++++++++++++++++
>  drivers/gpio/s5p_gpio.c                  |   44 ++++++++++++++++++++++++++++++
>  3 files changed, 86 insertions(+), 0 deletions(-)
>

applied to u-boot-samsung

Thanks
Minkyu Kang
diff mbox

Patch

diff --git a/arch/arm/include/asm/arch-s5pc1xx/gpio.h b/arch/arm/include/asm/arch-s5pc1xx/gpio.h
index 903de9c..76b901b 100644
--- a/arch/arm/include/asm/arch-s5pc1xx/gpio.h
+++ b/arch/arm/include/asm/arch-s5pc1xx/gpio.h
@@ -134,6 +134,19 @@  unsigned int s5p_gpio_get_value(struct s5p_gpio_bank *bank, int gpio);
 void s5p_gpio_set_pull(struct s5p_gpio_bank *bank, int gpio, int mode);
 void s5p_gpio_set_drv(struct s5p_gpio_bank *bank, int gpio, int mode);
 void s5p_gpio_set_rate(struct s5p_gpio_bank *bank, int gpio, int mode);
+
+/* GPIO pins per bank  */
+#define GPIO_PER_BANK 8
+
+static inline unsigned int s5p_gpio_base(int nr)
+{
+	return S5PC110_GPIO_BASE;
+}
+
+#define s5pc110_gpio_get_nr(bank, pin) \
+	((((((unsigned int)&(((struct s5pc110_gpio *)S5PC110_GPIO_BASE)->bank))\
+	    - S5PC110_GPIO_BASE) / sizeof(struct s5p_gpio_bank)) \
+	  * GPIO_PER_BANK) + pin)
 #endif
 
 /* Pin configurations */
diff --git a/arch/arm/include/asm/arch-s5pc2xx/gpio.h b/arch/arm/include/asm/arch-s5pc2xx/gpio.h
index 8db5895..8be620c 100644
--- a/arch/arm/include/asm/arch-s5pc2xx/gpio.h
+++ b/arch/arm/include/asm/arch-s5pc2xx/gpio.h
@@ -88,6 +88,35 @@  unsigned int s5p_gpio_get_value(struct s5p_gpio_bank *bank, int gpio);
 void s5p_gpio_set_pull(struct s5p_gpio_bank *bank, int gpio, int mode);
 void s5p_gpio_set_drv(struct s5p_gpio_bank *bank, int gpio, int mode);
 void s5p_gpio_set_rate(struct s5p_gpio_bank *bank, int gpio, int mode);
+
+/* GPIO pins per bank  */
+#define GPIO_PER_BANK 8
+
+#define s5pc210_gpio_part1_get_nr(bank, pin) \
+	((((((unsigned int) &(((struct s5pc210_gpio_part1 *) \
+			       S5PC210_GPIO_PART1_BASE)->bank)) \
+	    - S5PC210_GPIO_PART1_BASE) / sizeof(struct s5p_gpio_bank)) \
+	  * GPIO_PER_BANK) + pin)
+
+#define GPIO_PART1_MAX ((sizeof(struct s5pc210_gpio_part1) \
+			    / sizeof(struct s5p_gpio_bank)) * GPIO_PER_BANK)
+
+#define s5pc210_gpio_part2_get_nr(bank, pin) \
+	(((((((unsigned int) &(((struct s5pc210_gpio_part2 *) \
+				S5PC210_GPIO_PART2_BASE)->bank)) \
+	    - S5PC210_GPIO_PART2_BASE) / sizeof(struct s5p_gpio_bank)) \
+	  * GPIO_PER_BANK) + pin) + GPIO_PART1_MAX)
+
+static inline unsigned int s5p_gpio_base(int nr)
+{
+	if (nr < GPIO_PART1_MAX)
+		return S5PC210_GPIO_PART1_BASE;
+	else
+		return S5PC210_GPIO_PART2_BASE;
+
+	return 0;
+}
+
 #endif
 
 /* Pin configurations */
diff --git a/drivers/gpio/s5p_gpio.c b/drivers/gpio/s5p_gpio.c
index 2043859..1edf9a2 100644
--- a/drivers/gpio/s5p_gpio.c
+++ b/drivers/gpio/s5p_gpio.c
@@ -141,3 +141,47 @@  void s5p_gpio_set_rate(struct s5p_gpio_bank *bank, int gpio, int mode)
 
 	writel(value, &bank->drv);
 }
+
+struct s5p_gpio_bank *s5p_gpio_get_bank(int nr)
+{
+	int bank = nr / GPIO_PER_BANK;
+	bank *= sizeof(struct s5p_gpio_bank);
+
+	return (struct s5p_gpio_bank *) (s5p_gpio_base(nr) + bank);
+}
+
+int s5p_gpio_get_pin(int nr)
+{
+	return nr % GPIO_PER_BANK;
+}
+
+int gpio_request(int gpio, const char *label)
+{
+	return 0;
+}
+
+int gpio_direction_input(int nr)
+{
+	s5p_gpio_direction_input(s5p_gpio_get_bank(nr),
+				s5p_gpio_get_pin(nr));
+	return 0;
+}
+
+int gpio_direction_output(int nr, int value)
+{
+	s5p_gpio_direction_output(s5p_gpio_get_bank(nr),
+				 s5p_gpio_get_pin(nr), value);
+	return 0;
+}
+
+int gpio_get_value(int nr)
+{
+	return (int) s5p_gpio_get_value(s5p_gpio_get_bank(nr),
+				       s5p_gpio_get_pin(nr));
+}
+
+void gpio_set_value(int nr, int value)
+{
+	s5p_gpio_set_value(s5p_gpio_get_bank(nr),
+			  s5p_gpio_get_pin(nr), value);
+}