diff mbox series

[v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties

Message ID 20200917193754.542-1-krzk@kernel.org
State Not Applicable, archived
Headers show
Series [v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties | expand

Checks

Context Check Description
robh/checkpatch warning total: 0 errors, 1 warnings, 15 lines checked
robh/dt-meta-schema success

Commit Message

Krzysztof Kozlowski Sept. 17, 2020, 7:37 p.m. UTC
Add common properties appearing in DTSes (clock-names,
clock-output-names) with the common values (actually used in DTSes) to
fix dtbs_check warnings like:

  arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
    pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>

---

Changes since v1:
1. Define the names, as used in existing DTS files.
---
 .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Matti Vaittinen Sept. 18, 2020, 5:48 a.m. UTC | #1
Hi deeee Ho peeps!

On Thu, 2020-09-17 at 21:37 +0200, Krzysztof Kozlowski wrote:
> Add common properties appearing in DTSes (clock-names,
> clock-output-names) with the common values (actually used in DTSes)
> to
> fix dtbs_check warnings like:
> 
>   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
>     pmic@4b: 'clock-names', 'clock-output-names', do not match any of
> the regexes: 'pinctrl-[0-9]+'
> 
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> ---
> 
> Changes since v1:
> 1. Define the names, as used in existing DTS files.
> ---
>  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6
> ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/Documentation/devicetree/bindings/mfd/rohm,bd71837-
> pmic.yaml b/Documentation/devicetree/bindings/mfd/rohm,bd71837-
> pmic.yaml
> index 65018a019e1d..3bfdd33702ad 100644
> --- a/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
> +++ b/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
> @@ -32,9 +32,15 @@ properties:
>    clocks:
>      maxItems: 1
>  
> +  clock-names:
> +    const: osc

I guess existing board dtses use "osc" then? Ok.

>    "#clock-cells":
>      const: 0
>  
> +  clock-output-names:
> +    const: pmic_clk

This is not a strong opinion but I feel that pmic_clk is a bit too
generic name? I mean, what if there is a system with more than one
PMICs? (I don't see such use-case with the BD718x7 though - but perhaps
this can serve as a misleading example for other PMICs? For example
with the ROHM BD96801 family there may be multiple PMICs in one
system). Anyways - if Rob is happy with this then please go with it :)

Acked-By: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
 * 
Thanks again for improving these bindings! I am constantly struggling
with these x_x. Writing the bindings is probably hardest part of PMIC
driver development -_-;
Krzysztof Kozlowski Sept. 18, 2020, 6:58 a.m. UTC | #2
On Fri, 18 Sep 2020 at 07:48, Vaittinen, Matti
<Matti.Vaittinen@fi.rohmeurope.com> wrote:
>
> Hi deeee Ho peeps!
>
> On Thu, 2020-09-17 at 21:37 +0200, Krzysztof Kozlowski wrote:
> > Add common properties appearing in DTSes (clock-names,
> > clock-output-names) with the common values (actually used in DTSes)
> > to
> > fix dtbs_check warnings like:
> >
> >   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
> >     pmic@4b: 'clock-names', 'clock-output-names', do not match any of
> > the regexes: 'pinctrl-[0-9]+'
> >
> > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> >
> > ---
> >
> > Changes since v1:
> > 1. Define the names, as used in existing DTS files.
> > ---
> >  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6
> > ++++++
> >  1 file changed, 6 insertions(+)
> >
> > diff --git a/Documentation/devicetree/bindings/mfd/rohm,bd71837-
> > pmic.yaml b/Documentation/devicetree/bindings/mfd/rohm,bd71837-
> > pmic.yaml
> > index 65018a019e1d..3bfdd33702ad 100644
> > --- a/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
> > +++ b/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
> > @@ -32,9 +32,15 @@ properties:
> >    clocks:
> >      maxItems: 1
> >
> > +  clock-names:
> > +    const: osc
>
> I guess existing board dtses use "osc" then? Ok.

Yes.

>
> >    "#clock-cells":
> >      const: 0
> >
> > +  clock-output-names:
> > +    const: pmic_clk
>
> This is not a strong opinion but I feel that pmic_clk is a bit too
> generic name? I mean, what if there is a system with more than one
> PMICs? (I don't see such use-case with the BD718x7 though - but perhaps
> this can serve as a misleading example for other PMICs?

I don't expect two PMICs. Sometimes secondary device is added with few
regulators, e.g. a MUIC. Still only one device can supply the CPU and
probably this would be called PMIC.

> For example
> with the ROHM BD96801 family there may be multiple PMICs in one
> system). Anyways - if Rob is happy with this then please go with it :)

The name was taken from existing DTS files. That was Rob's idea as well.

Best regards,
Krzysztof

>
> Acked-By: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
>  *
> Thanks again for improving these bindings! I am constantly struggling
> with these x_x. Writing the bindings is probably hardest part of PMIC
> driver development -_-;
>
>
Rob Herring Sept. 23, 2020, 8:32 p.m. UTC | #3
On Thu, 17 Sep 2020 21:37:54 +0200, Krzysztof Kozlowski wrote:
> Add common properties appearing in DTSes (clock-names,
> clock-output-names) with the common values (actually used in DTSes) to
> fix dtbs_check warnings like:
> 
>   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
>     pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'
> 
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> ---
> 
> Changes since v1:
> 1. Define the names, as used in existing DTS files.
> ---
>  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
>  1 file changed, 6 insertions(+)
> 

Reviewed-by: Rob Herring <robh@kernel.org>
Krzysztof Kozlowski Oct. 2, 2020, 4:13 p.m. UTC | #4
On Thu, Sep 17, 2020 at 09:37:54PM +0200, Krzysztof Kozlowski wrote:
> Add common properties appearing in DTSes (clock-names,
> clock-output-names) with the common values (actually used in DTSes) to
> fix dtbs_check warnings like:
> 
>   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
>     pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'
> 
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> ---
> 
> Changes since v1:
> 1. Define the names, as used in existing DTS files.
> ---
>  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
>  1 file changed, 6 insertions(+)

Dear Lee,

Could you take it via MFD tree? There is a review from Rob and ack from
author (Matti).

Best regards,
Krzysztof
Lee Jones Oct. 5, 2020, 8:13 a.m. UTC | #5
On Fri, 02 Oct 2020, Krzysztof Kozlowski wrote:

> On Thu, Sep 17, 2020 at 09:37:54PM +0200, Krzysztof Kozlowski wrote:
> > Add common properties appearing in DTSes (clock-names,
> > clock-output-names) with the common values (actually used in DTSes) to
> > fix dtbs_check warnings like:
> > 
> >   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
> >     pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'
> > 
> > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> > 
> > ---
> > 
> > Changes since v1:
> > 1. Define the names, as used in existing DTS files.
> > ---
> >  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
> >  1 file changed, 6 insertions(+)
> 
> Dear Lee,
> 
> Could you take it via MFD tree? There is a review from Rob and ack from
> author (Matti).

I don't usually take patches this late in the cycle.
Lee Jones Nov. 4, 2020, 3:19 p.m. UTC | #6
On Thu, 17 Sep 2020, Krzysztof Kozlowski wrote:

> Add common properties appearing in DTSes (clock-names,
> clock-output-names) with the common values (actually used in DTSes) to
> fix dtbs_check warnings like:
> 
>   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
>     pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'
> 
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> ---
> 
> Changes since v1:
> 1. Define the names, as used in existing DTS files.
> ---
>  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
>  1 file changed, 6 insertions(+)

Applied, thanks.
diff mbox series

Patch

diff --git a/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml b/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
index 65018a019e1d..3bfdd33702ad 100644
--- a/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
+++ b/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
@@ -32,9 +32,15 @@  properties:
   clocks:
     maxItems: 1
 
+  clock-names:
+    const: osc
+
   "#clock-cells":
     const: 0
 
+  clock-output-names:
+    const: pmic_clk
+
 # The BD718x7 supports two different HW states as reset target states. States
 # are called as SNVS and READY. At READY state all the PMIC power outputs go
 # down and OTP is reload. At the SNVS state all other logic and external