diff mbox series

[v1,1/3] dt-bindings: vendor-prefixes: Add an entry for Van der Laan b.v.

Message ID 20201014085316.11916-1-o.rempel@pengutronix.de
State Superseded, archived
Headers show
Series [v1,1/3] dt-bindings: vendor-prefixes: Add an entry for Van der Laan b.v. | expand

Checks

Context Check Description
robh/checkpatch success
robh/dt-meta-schema success

Commit Message

Oleksij Rempel Oct. 14, 2020, 8:53 a.m. UTC
Add "vdl" entry for Van der Laan b.v.: https://www.teamvdl.nl/

Signed-off-by: Oleksij Rempel <o.rempel@pengutronix.de>
---
 Documentation/devicetree/bindings/vendor-prefixes.yaml | 2 ++
 1 file changed, 2 insertions(+)

Comments

Marco Felsch Oct. 14, 2020, 10:05 a.m. UTC | #1
Hi Oleksij,

pls can you send a patch adding this board to:
Documentation/devicetree/bindings/arm/fsl.yaml

infront of this patch?

On 20-10-14 10:53, Oleksij Rempel wrote:
> Van der Laan LANMCU is a module for the food storage rooms to control
> proper gas composition.
> 
> Co-Developed-by: Robin van der Gracht <robin@protonic.nl>
> Signed-off-by: Robin van der Gracht <robin@protonic.nl>
> Signed-off-by: Oleksij Rempel <o.rempel@pengutronix.de>
> ---
>  arch/arm/boot/dts/Makefile          |   1 +
>  arch/arm/boot/dts/imx6dl-lanmcu.dts | 468 ++++++++++++++++++++++++++++
>  2 files changed, 469 insertions(+)
>  create mode 100644 arch/arm/boot/dts/imx6dl-lanmcu.dts
> 
> diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
> index 2289a28c0ff6..dc2543a7b7e9 100644
> --- a/arch/arm/boot/dts/Makefile
> +++ b/arch/arm/boot/dts/Makefile
> @@ -447,6 +447,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
>  	imx6dl-icore.dtb \
>  	imx6dl-icore-mipi.dtb \
>  	imx6dl-icore-rqs.dtb \
> +	imx6dl-lanmcu.dtb \
>  	imx6dl-mamoj.dtb \
>  	imx6dl-nit6xlite.dtb \
>  	imx6dl-nitrogen6x.dtb \
> diff --git a/arch/arm/boot/dts/imx6dl-lanmcu.dts b/arch/arm/boot/dts/imx6dl-lanmcu.dts
> new file mode 100644
> index 000000000000..60336c972286
> --- /dev/null
> +++ b/arch/arm/boot/dts/imx6dl-lanmcu.dts
> @@ -0,0 +1,468 @@
> +// SPDX-License-Identifier: GPL-2.0-or-later
> +/*
> + * Copyright (c) 2019 Protonic Holland
> + * Copyright (c) 2020 Oleksij Rempel <kernel@pengutronix.de>, Pengutronix
> + */
> +
> +/dts-v1/;
> +#include <dt-bindings/gpio/gpio.h>
> +#include <dt-bindings/leds/common.h>
> +#include "imx6dl.dtsi"
> +
> +/ {

...

> +&fec {
> +	pinctrl-names = "default";
> +	pinctrl-0 = <&pinctrl_enet>;
> +	phy-mode = "rmii";
> +	clocks = <&clks IMX6QDL_CLK_ENET>,
> +		 <&clks IMX6QDL_CLK_ENET>,
> +		 <&clock_ksz8081>;
> +	clock-names = "ipg", "ahb", "ptp";
> +	status = "okay";
> +
> +	mdio {
> +		#address-cells = <1>;
> +		#size-cells = <0>;
> +
> +		/* Microchip KSZ8081RNA PHY */
> +		rgmii_phy: ethernet-phy@0 {

Do you need this phandle here?

> +			reg = <0>;
> +			interrupts-extended = <&gpio5 23 IRQ_TYPE_LEVEL_LOW>;
> +			reset-gpios = <&gpio5 22 GPIO_ACTIVE_LOW>;
> +			reset-assert-us = <10000>;
> +			reset-deassert-us = <300>;
> +		};
> +	};
> +};

...

> +&i2c3 {
> +	clock-frequency = <100000>;
> +	pinctrl-names = "default";
> +	pinctrl-0 = <&pinctrl_i2c3>;
> +	status = "okay";
> +
> +	edt-ft5406@38 {

Please use generic names like: touchscreen@38 or touchcontroller@38.

> +		compatible = "edt,edt-ft5406";
> +		pinctrl-names = "default";
> +		pinctrl-0 = <&pinctrl_ts_edt>;
> +		reg = <0x38>;

reg should be 2nd entry.

> +		interrupts-extended = <&gpio3 20 IRQ_TYPE_EDGE_FALLING>;
> +
> +		touchscreen-size-x = <1792>;
> +		touchscreen-size-y = <1024>;
> +
> +		touchscreen-fuzz-x = <0>;
> +		touchscreen-fuzz-y = <0>;
> +
> +		/* Touch screen calibration */
> +		threshold = <50>;
> +		gain = <5>;
> +		offset = <10>;
> +	};
> +
> +	rtc@51 {
> +		compatible = "nxp,pcf8563";
> +		reg = <0x51>;
> +	};
> +};

...

> +&usdhc2 {
> +	pinctrl-names = "default";
> +	pinctrl-0 = <&pinctrl_usdhc2>;
> +	no-1-8-v;
> +	non-removable;
> +	mmc-pwrseq = <&usdhc2_wifi_pwrseq>;
> +	status = "okay";

status is always the last property of this list.

> +	#address-cells = <1>;
> +	#size-cells = <0>;
> +
> +	brcmf: bcrmf@1 {
> +		reg = <1>;
> +		compatible = "brcm,bcm4329-fmac";
> +	};
> +};

Regards,
  Marco
Oleksij Rempel Oct. 15, 2020, 9:02 a.m. UTC | #2
Hi Marco,

thank you for review!

On Wed, Oct 14, 2020 at 12:05:01PM +0200, Marco Felsch wrote:
> Hi Oleksij,
> 
> pls can you send a patch adding this board to:
> Documentation/devicetree/bindings/arm/fsl.yaml
> 
> infront of this patch?

This is patch 3/3 and fsl.yaml 2/3. Do I'm missing some thing?

> On 20-10-14 10:53, Oleksij Rempel wrote:
> > Van der Laan LANMCU is a module for the food storage rooms to control
> > proper gas composition.
> > 
> > Co-Developed-by: Robin van der Gracht <robin@protonic.nl>
> > Signed-off-by: Robin van der Gracht <robin@protonic.nl>
> > Signed-off-by: Oleksij Rempel <o.rempel@pengutronix.de>
> > ---
> >  arch/arm/boot/dts/Makefile          |   1 +
> >  arch/arm/boot/dts/imx6dl-lanmcu.dts | 468 ++++++++++++++++++++++++++++
> >  2 files changed, 469 insertions(+)
> >  create mode 100644 arch/arm/boot/dts/imx6dl-lanmcu.dts
> > 
> > diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
> > index 2289a28c0ff6..dc2543a7b7e9 100644
> > --- a/arch/arm/boot/dts/Makefile
> > +++ b/arch/arm/boot/dts/Makefile
> > @@ -447,6 +447,7 @@ dtb-$(CONFIG_SOC_IMX6Q) += \
> >  	imx6dl-icore.dtb \
> >  	imx6dl-icore-mipi.dtb \
> >  	imx6dl-icore-rqs.dtb \
> > +	imx6dl-lanmcu.dtb \
> >  	imx6dl-mamoj.dtb \
> >  	imx6dl-nit6xlite.dtb \
> >  	imx6dl-nitrogen6x.dtb \
> > diff --git a/arch/arm/boot/dts/imx6dl-lanmcu.dts b/arch/arm/boot/dts/imx6dl-lanmcu.dts
> > new file mode 100644
> > index 000000000000..60336c972286
> > --- /dev/null
> > +++ b/arch/arm/boot/dts/imx6dl-lanmcu.dts
> > @@ -0,0 +1,468 @@
> > +// SPDX-License-Identifier: GPL-2.0-or-later
> > +/*
> > + * Copyright (c) 2019 Protonic Holland
> > + * Copyright (c) 2020 Oleksij Rempel <kernel@pengutronix.de>, Pengutronix
> > + */
> > +
> > +/dts-v1/;
> > +#include <dt-bindings/gpio/gpio.h>
> > +#include <dt-bindings/leds/common.h>
> > +#include "imx6dl.dtsi"
> > +
> > +/ {
> 
> ...
> 
> > +&fec {
> > +	pinctrl-names = "default";
> > +	pinctrl-0 = <&pinctrl_enet>;
> > +	phy-mode = "rmii";
> > +	clocks = <&clks IMX6QDL_CLK_ENET>,
> > +		 <&clks IMX6QDL_CLK_ENET>,
> > +		 <&clock_ksz8081>;
> > +	clock-names = "ipg", "ahb", "ptp";
> > +	status = "okay";
> > +
> > +	mdio {
> > +		#address-cells = <1>;
> > +		#size-cells = <0>;
> > +
> > +		/* Microchip KSZ8081RNA PHY */
> > +		rgmii_phy: ethernet-phy@0 {
> 
> Do you need this phandle here?

Fixed by adding phy-handle.

> > +			reg = <0>;
> > +			interrupts-extended = <&gpio5 23 IRQ_TYPE_LEVEL_LOW>;
> > +			reset-gpios = <&gpio5 22 GPIO_ACTIVE_LOW>;
> > +			reset-assert-us = <10000>;
> > +			reset-deassert-us = <300>;
> > +		};
> > +	};
> > +};
> 
> ...
> 
> > +&i2c3 {
> > +	clock-frequency = <100000>;
> > +	pinctrl-names = "default";
> > +	pinctrl-0 = <&pinctrl_i2c3>;
> > +	status = "okay";
> > +
> > +	edt-ft5406@38 {
> 
> Please use generic names like: touchscreen@38 or touchcontroller@38.

OK, i'll use "touchscreen@38".
touchcontroller@ this variant was never used in the mainline kernel.

> > +		compatible = "edt,edt-ft5406";
> > +		pinctrl-names = "default";
> > +		pinctrl-0 = <&pinctrl_ts_edt>;
> > +		reg = <0x38>;
> 
> reg should be 2nd entry.

done

> > +		interrupts-extended = <&gpio3 20 IRQ_TYPE_EDGE_FALLING>;
> > +
> > +		touchscreen-size-x = <1792>;
> > +		touchscreen-size-y = <1024>;
> > +
> > +		touchscreen-fuzz-x = <0>;
> > +		touchscreen-fuzz-y = <0>;
> > +
> > +		/* Touch screen calibration */
> > +		threshold = <50>;
> > +		gain = <5>;
> > +		offset = <10>;
> > +	};
> > +
> > +	rtc@51 {
> > +		compatible = "nxp,pcf8563";
> > +		reg = <0x51>;
> > +	};
> > +};
> 
> ...
> 
> > +&usdhc2 {
> > +	pinctrl-names = "default";
> > +	pinctrl-0 = <&pinctrl_usdhc2>;
> > +	no-1-8-v;
> > +	non-removable;
> > +	mmc-pwrseq = <&usdhc2_wifi_pwrseq>;
> > +	status = "okay";
> 
> status is always the last property of this list.

done

> > +	#address-cells = <1>;
> > +	#size-cells = <0>;
> > +
> > +	brcmf: bcrmf@1 {
> > +		reg = <1>;
> > +		compatible = "brcm,bcm4329-fmac";
> > +	};
> > +};
> 

Regards,
Oleksij
Marco Felsch Oct. 15, 2020, 11 a.m. UTC | #3
On 20-10-15 11:02, Oleksij Rempel wrote:
> Hi Marco,
> 
> thank you for review!
> 
> On Wed, Oct 14, 2020 at 12:05:01PM +0200, Marco Felsch wrote:
> > Hi Oleksij,
> > 
> > pls can you send a patch adding this board to:
> > Documentation/devicetree/bindings/arm/fsl.yaml
> > 
> > infront of this patch?
> 
> This is patch 3/3 and fsl.yaml 2/3. Do I'm missing some thing?

Argh.. didn't saw this patch 2/3..

Regards,
  Marco
diff mbox series

Patch

diff --git a/Documentation/devicetree/bindings/vendor-prefixes.yaml b/Documentation/devicetree/bindings/vendor-prefixes.yaml
index 801cc267349d..a570f96348a7 100644
--- a/Documentation/devicetree/bindings/vendor-prefixes.yaml
+++ b/Documentation/devicetree/bindings/vendor-prefixes.yaml
@@ -1120,6 +1120,8 @@  patternProperties:
     description: Vamrs Ltd.
   "^variscite,.*":
     description: Variscite Ltd.
+  "^vdl,.*":
+    description: Van der Laan b.v.
   "^via,.*":
     description: VIA Technologies, Inc.
   "^videostrong,.*":