diff mbox series

rtc: rx8010: rename rx8010_init_client() to rx8010_init()

Message ID 20200917114656.9036-1-brgl@bgdev.pl
State Accepted
Headers show
Series rtc: rx8010: rename rx8010_init_client() to rx8010_init() | expand

Commit Message

Bartosz Golaszewski Sept. 17, 2020, 11:46 a.m. UTC
From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

Since the switch to using regmap this function no longer takes the
I2C client struct as argument nor do we even interact with the client
anywhere other than when creating the regmap.

Rename it to a less misleading name: "rx8010_init()".

Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
---
 drivers/rtc/rtc-rx8010.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Alexandre Belloni Sept. 29, 2020, 8:18 p.m. UTC | #1
On Thu, 17 Sep 2020 13:46:56 +0200, Bartosz Golaszewski wrote:
> Since the switch to using regmap this function no longer takes the
> I2C client struct as argument nor do we even interact with the client
> anywhere other than when creating the regmap.
> 
> Rename it to a less misleading name: "rx8010_init()".

Applied, thanks!

[1/1] rtc: rx8010: rename rx8010_init_client() to rx8010_init()
      commit: ba1bcafb29571f525bf563972e4241998db74e98

Best regards,
diff mbox series

Patch

diff --git a/drivers/rtc/rtc-rx8010.c b/drivers/rtc/rtc-rx8010.c
index 01e9017d4025..dca41a2a39b2 100644
--- a/drivers/rtc/rtc-rx8010.c
+++ b/drivers/rtc/rtc-rx8010.c
@@ -169,7 +169,7 @@  static int rx8010_set_time(struct device *dev, struct rtc_time *dt)
 	return 0;
 }
 
-static int rx8010_init_client(struct device *dev)
+static int rx8010_init(struct device *dev)
 {
 	struct rx8010_data *rx8010 = dev_get_drvdata(dev);
 	u8 ctrl[2];
@@ -391,7 +391,7 @@  static int rx8010_probe(struct i2c_client *client)
 	if (IS_ERR(rx8010->regs))
 		return PTR_ERR(rx8010->regs);
 
-	err = rx8010_init_client(dev);
+	err = rx8010_init(dev);
 	if (err)
 		return err;