diff mbox series

target/arm: Rename function disas_ldst_pac to disas_ld_pac

Message ID 20200804002712.27733-1-pcc@google.com
State New
Headers show
Series target/arm: Rename function disas_ldst_pac to disas_ld_pac | expand

Commit Message

Peter Collingbourne Aug. 4, 2020, 12:27 a.m. UTC
The name disas_ldst_pac is misleading as it implies the existence
of authenticating store instructions, so rename it to avoid that
implication.

Signed-off-by: Peter Collingbourne <pcc@google.com>
---
 target/arm/translate-a64.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Peter Maydell Aug. 4, 2020, 9:34 a.m. UTC | #1
On Tue, 4 Aug 2020 at 01:27, Peter Collingbourne <pcc@google.com> wrote:
>
> The name disas_ldst_pac is misleading as it implies the existence
> of authenticating store instructions, so rename it to avoid that
> implication.
>
> Signed-off-by: Peter Collingbourne <pcc@google.com>

The use of ldst here matches the name of this group of instructions
in the Arm ARM (DDI0487F.c page C4-308, "Load/store register (pac)"),
I think.

thanks
-- PMM
diff mbox series

Patch

diff --git a/target/arm/translate-a64.c b/target/arm/translate-a64.c
index 8c0764957c..749de2e509 100644
--- a/target/arm/translate-a64.c
+++ b/target/arm/translate-a64.c
@@ -3408,8 +3408,8 @@  static void disas_ldst_atomic(DisasContext *s, uint32_t insn,
  * W: pre-indexing flag
  * S: sign for imm9.
  */
-static void disas_ldst_pac(DisasContext *s, uint32_t insn,
-                           int size, int rt, bool is_vector)
+static void disas_ld_pac(DisasContext *s, uint32_t insn,
+                         int size, int rt, bool is_vector)
 {
     int rn = extract32(insn, 5, 5);
     bool is_wback = extract32(insn, 11, 1);
@@ -3562,7 +3562,7 @@  static void disas_ldst_reg(DisasContext *s, uint32_t insn)
             disas_ldst_reg_roffset(s, insn, opc, size, rt, is_vector);
             return;
         default:
-            disas_ldst_pac(s, insn, size, rt, is_vector);
+            disas_ld_pac(s, insn, size, rt, is_vector);
             return;
         }
         break;