diff mbox

target-ppc: use softfloat min/max functions

Message ID 1303154610-30666-1-git-send-email-aurelien@aurel32.net
State New
Headers show

Commit Message

Aurelien Jarno April 18, 2011, 7:23 p.m. UTC
Use the new softfloat float32_min() and float32_max() to implement the
vminfp and vmaxfp instructions.

Cc: Alexander Graf <agraf@suse.de>
Signed-off-by: Aurelien Jarno <aurelien@aurel32.net>
---
 target-ppc/op_helper.c |   16 +++++-----------
 1 files changed, 5 insertions(+), 11 deletions(-)

Comments

Peter Maydell April 18, 2011, 8:28 p.m. UTC | #1
On 18 April 2011 20:23, Aurelien Jarno <aurelien@aurel32.net> wrote:
> diff --git a/target-ppc/op_helper.c b/target-ppc/op_helper.c
> index 9aa108e..9058d78 100644
> --- a/target-ppc/op_helper.c
> +++ b/target-ppc/op_helper.c
> @@ -2369,22 +2369,16 @@ VMINMAX(uw, u32)
>  #undef VMINMAX_DO
>  #undef VMINMAX
>
> -#define VMINMAXFP(suffix, rT, rF)                                       \
> -    void helper_v##suffix (ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b)    \
> +#define VMINMAXFP(suffix)                                               \
> +    void helper_v##suffix##fp (ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b)\
>     {                                                                   \
>         int i;                                                          \
>         for (i = 0; i < ARRAY_SIZE(r->f); i++) {                        \
> -            HANDLE_NAN2(r->f[i], a->f[i], b->f[i]) {                    \
> -                if (float32_lt_quiet(a->f[i], b->f[i], &env->vec_status)) { \
> -                    r->f[i] = rT->f[i];                                 \
> -                } else {                                                \
> -                    r->f[i] = rF->f[i];                                 \
> -                }                                                       \
> -            }                                                           \
> +            r->f[i] = float32_##suffix(a->f[i], b->f[i], &env->vec_status); \
>         }                                                               \
>     }
> -VMINMAXFP(minfp, a, b)
> -VMINMAXFP(maxfp, b, a)
> +VMINMAXFP(min)
> +VMINMAXFP(max)
>  #undef VMINMAXFP
>
>  void helper_vmladduhm (ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b, ppc_avr_t *c)

I think you should be able to remove the HANDLE_NAN2 line from the
VARITHFP macro (used for vaddfp, vsubfp) and then you can just say
 VARITHFP(minfp, float32_min)
 VARITHFP(maxfp, float32_max)
rather than needing a separate macro for them, right?

-- PMM
Alexander Graf April 18, 2011, 9:15 p.m. UTC | #2
On 18.04.2011, at 21:23, Aurelien Jarno wrote:

> Use the new softfloat float32_min() and float32_max() to implement the
> vminfp and vmaxfp instructions.
> 
> Cc: Alexander Graf <agraf@suse.de>
> Signed-off-by: Aurelien Jarno <aurelien@aurel32.net>
> ---
> target-ppc/op_helper.c |   16 +++++-----------
> 1 files changed, 5 insertions(+), 11 deletions(-)
> 
> diff --git a/target-ppc/op_helper.c b/target-ppc/op_helper.c
> index 9aa108e..9058d78 100644
> --- a/target-ppc/op_helper.c
> +++ b/target-ppc/op_helper.c
> @@ -2369,22 +2369,16 @@ VMINMAX(uw, u32)
> #undef VMINMAX_DO
> #undef VMINMAX
> 
> -#define VMINMAXFP(suffix, rT, rF)                                       \
> -    void helper_v##suffix (ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b)    \
> +#define VMINMAXFP(suffix)                                               \
> +    void helper_v##suffix##fp (ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b)\
>     {                                                                   \
>         int i;                                                          \
>         for (i = 0; i < ARRAY_SIZE(r->f); i++) {                        \
> -            HANDLE_NAN2(r->f[i], a->f[i], b->f[i]) {                    \
> -                if (float32_lt_quiet(a->f[i], b->f[i], &env->vec_status)) { \
> -                    r->f[i] = rT->f[i];                                 \
> -                } else {                                                \
> -                    r->f[i] = rF->f[i];                                 \
> -                }                                                       \
> -            }                                                           \
> +            r->f[i] = float32_##suffix(a->f[i], b->f[i], &env->vec_status); \

Now that you've removed all the magic from the macro, it'd probably be easier to read if you open coded it, no? :)


Alex
diff mbox

Patch

diff --git a/target-ppc/op_helper.c b/target-ppc/op_helper.c
index 9aa108e..9058d78 100644
--- a/target-ppc/op_helper.c
+++ b/target-ppc/op_helper.c
@@ -2369,22 +2369,16 @@  VMINMAX(uw, u32)
 #undef VMINMAX_DO
 #undef VMINMAX
 
-#define VMINMAXFP(suffix, rT, rF)                                       \
-    void helper_v##suffix (ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b)    \
+#define VMINMAXFP(suffix)                                               \
+    void helper_v##suffix##fp (ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b)\
     {                                                                   \
         int i;                                                          \
         for (i = 0; i < ARRAY_SIZE(r->f); i++) {                        \
-            HANDLE_NAN2(r->f[i], a->f[i], b->f[i]) {                    \
-                if (float32_lt_quiet(a->f[i], b->f[i], &env->vec_status)) { \
-                    r->f[i] = rT->f[i];                                 \
-                } else {                                                \
-                    r->f[i] = rF->f[i];                                 \
-                }                                                       \
-            }                                                           \
+            r->f[i] = float32_##suffix(a->f[i], b->f[i], &env->vec_status); \
         }                                                               \
     }
-VMINMAXFP(minfp, a, b)
-VMINMAXFP(maxfp, b, a)
+VMINMAXFP(min)
+VMINMAXFP(max)
 #undef VMINMAXFP
 
 void helper_vmladduhm (ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b, ppc_avr_t *c)