diff mbox series

[v2] linux-user: rename gettid() to sys_gettid() to avoid clash with glibc

Message ID 20190320122555.8025-1-berrange@redhat.com
State New
Headers show
Series [v2] linux-user: rename gettid() to sys_gettid() to avoid clash with glibc | expand

Commit Message

Daniel P. Berrangé March 20, 2019, 12:25 p.m. UTC
The glibc-2.29.9000-6.fc31.x86_64 package finally includes the gettid()
function as part of unistd.h when __USE_GNU is defined. This clashes
with linux-user code which unconditionally defines this function name
itself.

/home/berrange/src/virt/qemu/linux-user/syscall.c:253:16: error: static declaration of ‘gettid’ follows non-static declaration
  253 | _syscall0(int, gettid)
      |                ^~~~~~
/home/berrange/src/virt/qemu/linux-user/syscall.c:184:13: note: in definition of macro ‘_syscall0’
  184 | static type name (void)   \
      |             ^~~~
In file included from /usr/include/unistd.h:1170,
                 from /home/berrange/src/virt/qemu/include/qemu/osdep.h:107,
                 from /home/berrange/src/virt/qemu/linux-user/syscall.c:20:
/usr/include/bits/unistd_ext.h:34:16: note: previous declaration of ‘gettid’ was here
   34 | extern __pid_t gettid (void) __THROW;
      |                ^~~~~~
  CC      aarch64-linux-user/linux-user/signal.o
make[1]: *** [/home/berrange/src/virt/qemu/rules.mak:69: linux-user/syscall.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [Makefile:449: subdir-aarch64-linux-user] Error 2

While we could make our definition conditional and rely on glibc's impl,
this patch simply renames our definition to sys_gettid() which is a
common pattern in this file.

Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
---

Changed in v2:

 - Rename to sys_gettid instead of using conditional compilation

 linux-user/syscall.c | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)

Comments

no-reply@patchew.org March 20, 2019, 12:30 p.m. UTC | #1
Patchew URL: https://patchew.org/QEMU/20190320122555.8025-1-berrange@redhat.com/



Hi,

This series seems to have some coding style problems. See output below for
more information:

Message-id: 20190320122555.8025-1-berrange@redhat.com
Subject: [Qemu-devel] [PATCH v2] linux-user: rename gettid() to sys_gettid() to avoid clash with glibc
Type: series

=== TEST SCRIPT BEGIN ===
#!/bin/bash
git rev-parse base > /dev/null || exit 0
git config --local diff.renamelimit 0
git config --local diff.renames True
git config --local diff.algorithm histogram
./scripts/checkpatch.pl --mailback base..
=== TEST SCRIPT END ===

Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
From https://github.com/patchew-project/qemu
 * [new tag]               patchew/20190320122555.8025-1-berrange@redhat.com -> patchew/20190320122555.8025-1-berrange@redhat.com
Switched to a new branch 'test'
d90b5f3892 linux-user: rename gettid() to sys_gettid() to avoid clash with glibc

=== OUTPUT BEGIN ===
ERROR: open brace '{' following function declarations go on the next line
#45: FILE: linux-user/syscall.c:253:
+static int sys_gettid(void) {

ERROR: open brace '{' following function declarations go on the next line
#52: FILE: linux-user/syscall.c:259:
+static int sys_gettid(void) {

total: 2 errors, 0 warnings, 42 lines checked

Commit d90b5f3892f5 (linux-user: rename gettid() to sys_gettid() to avoid clash with glibc) has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.
=== OUTPUT END ===

Test command exited with code: 1


The full log is available at
http://patchew.org/logs/20190320122555.8025-1-berrange@redhat.com/testing.checkpatch/?type=message.
---
Email generated automatically by Patchew [https://patchew.org/].
Please send your feedback to patchew-devel@redhat.com
diff mbox series

Patch

diff --git a/linux-user/syscall.c b/linux-user/syscall.c
index 208fd1813d..c47cf66346 100644
--- a/linux-user/syscall.c
+++ b/linux-user/syscall.c
@@ -250,11 +250,13 @@  static type name (type1 arg1,type2 arg2,type3 arg3,type4 arg4,type5 arg5,	\
 #endif
 
 #ifdef __NR_gettid
-_syscall0(int, gettid)
+static int sys_gettid(void) {
+    return syscall(__NR_gettid);
+}
 #else
 /* This is a replacement for the host gettid() and must return a host
    errno. */
-static int gettid(void) {
+static int sys_gettid(void) {
     return -ENOSYS;
 }
 #endif
@@ -5442,7 +5444,7 @@  static void *clone_func(void *arg)
     cpu = ENV_GET_CPU(env);
     thread_cpu = cpu;
     ts = (TaskState *)cpu->opaque;
-    info->tid = gettid();
+    info->tid = sys_gettid();
     task_settid(ts);
     if (info->child_tidptr)
         put_user_u32(info->tid, info->child_tidptr);
@@ -5587,9 +5589,9 @@  static int do_fork(CPUArchState *env, unsigned int flags, abi_ulong newsp,
                mapping.  We can't repeat the spinlock hack used above because
                the child process gets its own copy of the lock.  */
             if (flags & CLONE_CHILD_SETTID)
-                put_user_u32(gettid(), child_tidptr);
+                put_user_u32(sys_gettid(), child_tidptr);
             if (flags & CLONE_PARENT_SETTID)
-                put_user_u32(gettid(), parent_tidptr);
+                put_user_u32(sys_gettid(), parent_tidptr);
             ts = (TaskState *)cpu->opaque;
             if (flags & CLONE_SETTLS)
                 cpu_set_tls (env, newtls);
@@ -10629,7 +10631,7 @@  static abi_long do_syscall1(void *cpu_env, int num, abi_long arg1,
         return TARGET_PAGE_SIZE;
 #endif
     case TARGET_NR_gettid:
-        return get_errno(gettid());
+        return get_errno(sys_gettid());
 #ifdef TARGET_NR_readahead
     case TARGET_NR_readahead:
 #if TARGET_ABI_BITS == 32