diff mbox

[2/5] gpio: gpiolib: Print error number if gpio hog failed

Message ID 1457438528-29054-3-git-send-email-ldewangan@nvidia.com
State New
Headers show

Commit Message

Laxman Dewangan March 8, 2016, 12:02 p.m. UTC
Print the error number of GPIO hog failed during
its configurations. This helps in identifying the
failure without instrumenting the code.

Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
---
 drivers/gpio/gpiolib.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

Comments

Vladimir Zapolskiy March 8, 2016, 12:27 p.m. UTC | #1
On 08.03.2016 14:02, Laxman Dewangan wrote:
> Print the error number of GPIO hog failed during
> its configurations. This helps in identifying the
> failure without instrumenting the code.
> 
> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
> ---
>  drivers/gpio/gpiolib.c | 9 +++++----
>  1 file changed, 5 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
> index bc788b9..7575ebb 100644
> --- a/drivers/gpio/gpiolib.c
> +++ b/drivers/gpio/gpiolib.c
> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name,
>  
>  	local_desc = gpiochip_request_own_desc(chip, hwnum, name);
>  	if (IS_ERR(local_desc)) {
> -		pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
> -		       name, chip->label, hwnum);
> +		status = PTR_ERR(local_desc);
> +		pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n",
> +		       name, chip->label, hwnum, status);
>  		return PTR_ERR(local_desc);

You can do "return status;" now.

>  	}
>  
>  	status = gpiod_configure_flags(desc, name, dflags);
>  	if (status < 0) {
> -		pr_err("setup of hog GPIO %s (chip %s, offset %d) failed\n",
> -		       name, chip->label, hwnum);
> +		pr_err("setup of hog GPIO %s chip %s, offset %d failed %d\n",
> +		       name, chip->label, hwnum, status);
>  		gpiochip_free_own_desc(desc);
>  		return status;
>  	}
> 

--
With best wishes,
Vladimir
--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Thierry Reding March 8, 2016, 2:22 p.m. UTC | #2
On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote:
> Print the error number of GPIO hog failed during
> its configurations. This helps in identifying the
> failure without instrumenting the code.

Please use up all 72 characters per line at your disposal. Excessively
short lines are hard to read.

> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
> ---
>  drivers/gpio/gpiolib.c | 9 +++++----
>  1 file changed, 5 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
> index bc788b9..7575ebb 100644
> --- a/drivers/gpio/gpiolib.c
> +++ b/drivers/gpio/gpiolib.c
> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name,
>  
>  	local_desc = gpiochip_request_own_desc(chip, hwnum, name);
>  	if (IS_ERR(local_desc)) {
> -		pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
> -		       name, chip->label, hwnum);
> +		status = PTR_ERR(local_desc);
> +		pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n",
> +		       name, chip->label, hwnum, status);

I find this type of format hard to read. I prefer a semi-colon to
separate the message from the failure reason (i.e. error code).

Besides that I don't understand why you're dropping the parentheses
around the "chip %s, offset %d", I found that easier on the eye.

Thierry
Laxman Dewangan March 8, 2016, 3:32 p.m. UTC | #3
On Tuesday 08 March 2016 07:52 PM, Thierry Reding wrote:
> On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote:
>
>> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
>> ---
>>   drivers/gpio/gpiolib.c | 9 +++++----
>>   1 file changed, 5 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
>> index bc788b9..7575ebb 100644
>> --- a/drivers/gpio/gpiolib.c
>> +++ b/drivers/gpio/gpiolib.c
>> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name,
>>   
>>   	local_desc = gpiochip_request_own_desc(chip, hwnum, name);
>>   	if (IS_ERR(local_desc)) {
>> -		pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
>> -		       name, chip->label, hwnum);
>> +		status = PTR_ERR(local_desc);
>> +		pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n",
>> +		       name, chip->label, hwnum, status);
> I find this type of format hard to read. I prefer a semi-colon to
> separate the message from the failure reason (i.e. error code).
>
> Besides that I don't understand why you're dropping the parentheses
> around the "chip %s, offset %d", I found that easier on the eye.
>
>


I did to accommodate the  3 extra character ( %d) for string format on 
that line as it was already near to 80 column.
Just did not want to split in multiple lines.

--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Stephen Warren March 9, 2016, 5:07 p.m. UTC | #4
On 03/08/2016 08:32 AM, Laxman Dewangan wrote:
>
> On Tuesday 08 March 2016 07:52 PM, Thierry Reding wrote:
>> On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote:
>>
>>> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
>>> ---
>>>   drivers/gpio/gpiolib.c | 9 +++++----
>>>   1 file changed, 5 insertions(+), 4 deletions(-)
>>>
>>> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
>>> index bc788b9..7575ebb 100644
>>> --- a/drivers/gpio/gpiolib.c
>>> +++ b/drivers/gpio/gpiolib.c
>>> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const
>>> char *name,
>>>       local_desc = gpiochip_request_own_desc(chip, hwnum, name);
>>>       if (IS_ERR(local_desc)) {
>>> -        pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
>>> -               name, chip->label, hwnum);
>>> +        status = PTR_ERR(local_desc);
>>> +        pr_err("requesting hog GPIO %s, chip %s, offset %d failed
>>> %d\n",
>>> +               name, chip->label, hwnum, status);
>> I find this type of format hard to read. I prefer a semi-colon to
>> separate the message from the failure reason (i.e. error code).
>>
>> Besides that I don't understand why you're dropping the parentheses
>> around the "chip %s, offset %d", I found that easier on the eye.
>
> I did to accommodate the  3 extra character ( %d) for string format on
> that line as it was already near to 80 column.
> Just did not want to split in multiple lines.

Note that strings shouldn't be split across lines since it makes it 
harder to grep for them. This is one case where the 80-column limit 
isn't strict, within reason.
--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Laxman Dewangan March 10, 2016, 6:58 a.m. UTC | #5
On Wednesday 09 March 2016 10:37 PM, Stephen Warren wrote:
> On 03/08/2016 08:32 AM, Laxman Dewangan wrote:
>>
>> On Tuesday 08 March 2016 07:52 PM, Thierry Reding wrote:
>>> On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote:
>>>
>>>> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>
>>>> ---
>>>>   drivers/gpio/gpiolib.c | 9 +++++----
>>>>   1 file changed, 5 insertions(+), 4 deletions(-)
>>>>
>>>> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
>>>> index bc788b9..7575ebb 100644
>>>> --- a/drivers/gpio/gpiolib.c
>>>> +++ b/drivers/gpio/gpiolib.c
>>>> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const
>>>> char *name,
>>>>       local_desc = gpiochip_request_own_desc(chip, hwnum, name);
>>>>       if (IS_ERR(local_desc)) {
>>>> -        pr_err("requesting hog GPIO %s (chip %s, offset %d) 
>>>> failed\n",
>>>> -               name, chip->label, hwnum);
>>>> +        status = PTR_ERR(local_desc);
>>>> +        pr_err("requesting hog GPIO %s, chip %s, offset %d failed
>>>> %d\n",
>>>> +               name, chip->label, hwnum, status);
>>> I find this type of format hard to read. I prefer a semi-colon to
>>> separate the message from the failure reason (i.e. error code).
>>>
>>> Besides that I don't understand why you're dropping the parentheses
>>> around the "chip %s, offset %d", I found that easier on the eye.
>>
>> I did to accommodate the  3 extra character ( %d) for string format on
>> that line as it was already near to 80 column.
>> Just did not want to split in multiple lines.
>
> Note that strings shouldn't be split across lines since it makes it 
> harder to grep for them. This is one case where the 80-column limit 
> isn't strict, within reason.

OK, so not change the existing string, just add new  format.


--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
index bc788b9..7575ebb 100644
--- a/drivers/gpio/gpiolib.c
+++ b/drivers/gpio/gpiolib.c
@@ -2621,15 +2621,16 @@  int gpiod_hog(struct gpio_desc *desc, const char *name,
 
 	local_desc = gpiochip_request_own_desc(chip, hwnum, name);
 	if (IS_ERR(local_desc)) {
-		pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n",
-		       name, chip->label, hwnum);
+		status = PTR_ERR(local_desc);
+		pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n",
+		       name, chip->label, hwnum, status);
 		return PTR_ERR(local_desc);
 	}
 
 	status = gpiod_configure_flags(desc, name, dflags);
 	if (status < 0) {
-		pr_err("setup of hog GPIO %s (chip %s, offset %d) failed\n",
-		       name, chip->label, hwnum);
+		pr_err("setup of hog GPIO %s chip %s, offset %d failed %d\n",
+		       name, chip->label, hwnum, status);
 		gpiochip_free_own_desc(desc);
 		return status;
 	}