diff mbox

[U-Boot,v3,6/8] nios2: define _end in link script

Message ID 1441420887-6555-1-git-send-email-thomas@wytron.com.tw
State Superseded
Delegated to: Thomas Chou
Headers show

Commit Message

Thomas Chou Sept. 5, 2015, 2:41 a.m. UTC
Since commit 44c6e6591cb451ae606f8bde71dd5fb7b4002544
"rename _end to __bss_end__" , the _end was removed.
But we need it now for separated device tree control,
ie, CONFIG_OF_SEPARATE .

The _end is used by fdtdec_setup() to find the blob.

Signed-off-by: Thomas Chou <thomas@wytron.com.tw>
Acked-by: Marek Vasut <marex@denx.de>
Reviewed-by: Simon Glass <sjg@chromium.org>
---

v3 comment coding style fix

 arch/nios2/cpu/u-boot.lds | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Marek Vasut Sept. 5, 2015, 12:49 p.m. UTC | #1
On Saturday, September 05, 2015 at 04:41:27 AM, Thomas Chou wrote:
> Since commit 44c6e6591cb451ae606f8bde71dd5fb7b4002544
> "rename _end to __bss_end__" , the _end was removed.
> But we need it now for separated device tree control,
> ie, CONFIG_OF_SEPARATE .
> 
> The _end is used by fdtdec_setup() to find the blob.
> 
> Signed-off-by: Thomas Chou <thomas@wytron.com.tw>
> Acked-by: Marek Vasut <marex@denx.de>
> Reviewed-by: Simon Glass <sjg@chromium.org>
> ---
> 
> v3 comment coding style fix
> 
>  arch/nios2/cpu/u-boot.lds | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/arch/nios2/cpu/u-boot.lds b/arch/nios2/cpu/u-boot.lds
> index 8b0fd1a..9d13ecc 100644
> --- a/arch/nios2/cpu/u-boot.lds
> +++ b/arch/nios2/cpu/u-boot.lds
> @@ -67,6 +67,12 @@ SECTIONS
>  	_edata = .;
>  	PROVIDE (edata = .);
> 
> +	/*
> +	 * _end - This is end of u-boot.bin image.
> +	 * dtb will be appended here to make u-boot-dtb.bin
> +         */

Still broken ;-)

btw. please either repost the whole series or use git send-email --in-reply-to ,
so I dont have to hunt down patches all over the place.

> +	_end = .;
> +
>  	/* UNINIT DATA - Small uninitialized data is first so it's
>  	 * adjacent to sdata and can be referenced via gp. The normal
>  	 * bss follows. We keep it adjacent to simplify init code.

Best regards,
Marek Vasut
diff mbox

Patch

diff --git a/arch/nios2/cpu/u-boot.lds b/arch/nios2/cpu/u-boot.lds
index 8b0fd1a..9d13ecc 100644
--- a/arch/nios2/cpu/u-boot.lds
+++ b/arch/nios2/cpu/u-boot.lds
@@ -67,6 +67,12 @@  SECTIONS
 	_edata = .;
 	PROVIDE (edata = .);
 
+	/*
+	 * _end - This is end of u-boot.bin image.
+	 * dtb will be appended here to make u-boot-dtb.bin
+         */
+	_end = .;
+
 	/* UNINIT DATA - Small uninitialized data is first so it's
 	 * adjacent to sdata and can be referenced via gp. The normal
 	 * bss follows. We keep it adjacent to simplify init code.