diff mbox

[1/8] virtio: Remove duplicate macro definition for max. virtqueues, bump up the max

Message ID 1263928018-32531-2-git-send-email-amit.shah@redhat.com
State New
Headers show

Commit Message

Amit Shah Jan. 19, 2010, 7:06 p.m. UTC
VIRTIO_PCI_QUEUE_MAX is redefined in hw/virtio.c. Let's just keep it in
hw/virtio.h.

Also, bump up the value of the maximum allowed virtqueues to 64. This is
in preparation to allow multiple ports per virtio-console device.

Signed-off-by: Amit Shah <amit.shah@redhat.com>
---
 hw/virtio.c |    2 --
 hw/virtio.h |    2 +-
 2 files changed, 1 insertions(+), 3 deletions(-)

Comments

Anthony Liguori Jan. 20, 2010, 2:56 p.m. UTC | #1
On 01/19/2010 01:06 PM, Amit Shah wrote:
> VIRTIO_PCI_QUEUE_MAX is redefined in hw/virtio.c. Let's just keep it in
> hw/virtio.h.
>
> Also, bump up the value of the maximum allowed virtqueues to 64. This is
> in preparation to allow multiple ports per virtio-console device.
>
> Signed-off-by: Amit Shah<amit.shah@redhat.com>
>    

Applied.  Thanks.

Regards,

Anthony Liguori
> ---
>   hw/virtio.c |    2 --
>   hw/virtio.h |    2 +-
>   2 files changed, 1 insertions(+), 3 deletions(-)
>
> diff --git a/hw/virtio.c b/hw/virtio.c
> index fa7184a..7c020a3 100644
> --- a/hw/virtio.c
> +++ b/hw/virtio.c
> @@ -75,8 +75,6 @@ struct VirtQueue
>       void (*handle_output)(VirtIODevice *vdev, VirtQueue *vq);
>   };
>
> -#define VIRTIO_PCI_QUEUE_MAX        16
> -
>   /* virt queue functions */
>   static void virtqueue_init(VirtQueue *vq)
>   {
> diff --git a/hw/virtio.h b/hw/virtio.h
> index 3994cc9..7b2b327 100644
> --- a/hw/virtio.h
> +++ b/hw/virtio.h
> @@ -90,7 +90,7 @@ typedef struct {
>       unsigned (*get_features)(void * opaque);
>   } VirtIOBindings;
>
> -#define VIRTIO_PCI_QUEUE_MAX 16
> +#define VIRTIO_PCI_QUEUE_MAX 64
>
>   #define VIRTIO_NO_VECTOR 0xffff
>
>
Markus Armbruster Jan. 21, 2010, 9:53 a.m. UTC | #2
Amit, what about renaming hw/virtio-serial.c to a less misleading name
now?
Amit Shah Jan. 21, 2010, 9:58 a.m. UTC | #3
On (Thu) Jan 21 2010 [10:53:36], Markus Armbruster wrote:
> Amit, what about renaming hw/virtio-serial.c to a less misleading name
> now?

I'm going to push that upstream; Anthony in the past indicated he was ok
with it.

		Amit
diff mbox

Patch

diff --git a/hw/virtio.c b/hw/virtio.c
index fa7184a..7c020a3 100644
--- a/hw/virtio.c
+++ b/hw/virtio.c
@@ -75,8 +75,6 @@  struct VirtQueue
     void (*handle_output)(VirtIODevice *vdev, VirtQueue *vq);
 };
 
-#define VIRTIO_PCI_QUEUE_MAX        16
-
 /* virt queue functions */
 static void virtqueue_init(VirtQueue *vq)
 {
diff --git a/hw/virtio.h b/hw/virtio.h
index 3994cc9..7b2b327 100644
--- a/hw/virtio.h
+++ b/hw/virtio.h
@@ -90,7 +90,7 @@  typedef struct {
     unsigned (*get_features)(void * opaque);
 } VirtIOBindings;
 
-#define VIRTIO_PCI_QUEUE_MAX 16
+#define VIRTIO_PCI_QUEUE_MAX 64
 
 #define VIRTIO_NO_VECTOR 0xffff